Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Werte anzeigen, wenn Bedingungen erfüllt sind
#1
Guten Morgen geschätzte Community

Ich habe eine Herausforderung in Excel (Office 365 ProPlus). Konkret: 

Ich habe eine Tabelle mit rund 6000 Zeilen (Sales Reporting). Nun möchte ich in einer zweiten Tabelle Werte ausgeben, die gewissen Bedingungen entsprechen, damit ich nicht immer Filtern muss. Am besten visualisiere ich das mal: 

Ausgangstabelle (stark vereinfacht)
[ Bild bitte als Datei hochladen! ]

Zieltabelle: 
[ Bild bitte als Datei hochladen! ]

In der Zieltabelle sollen jeweils Kunde, Sendung und Betrag aller Offerten (Spalte "Status) von Peter (Spalte "Sales") angezeigt werden. 

Hat jemand eine kreative Idee?

Liebe Grüsse
Michi
Antwortento top
#2
Moin Michi,

lad mal bitte eine Beispieldatei (.xlsx- keine Bildchen!!) hoch. https://www.clever-excel-forum.de/Thread...ng-stellen

Von deiner Beschreibung abgeleitet, könnte eventuell INDEX/AGGREGAT() helfen.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
Hallo Michi,

Bitte beachte die Uploadmöglichkeiten in unserem Forum.
Ansonsten, schaue Dir mal den Autofilter_per_Formel an, oder eventuell hilft auch Pivot ...
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#4
Sorry - hier die Beispieldatei


Angehängte Dateien
.xlsx   Beispieldatei.xlsx (Größe: 11,48 KB / Downloads: 3)
Antwortento top
#5
Hi,

wie bereits vermutet:
Arbeitsblatt mit dem Namen 'Zieltabelle'
ABC
1SalesPeter
2
3KundeSendungBetrag
4ATest 18
5DTest 412
6ATest 9136
7
8
9
10

ZelleFormel
A4=WENNFEHLER(INDEX(Ausgangstabelle!A:A;AGGREGAT(15;6;ZEILE(Ausgangstabelle!$B$1:$B$20)/(Ausgangstabelle!$B$1:$B$20=Zieltabelle!$B$1);ZEILE(A1)));"")
B4=WENNFEHLER(INDEX(Ausgangstabelle!C:C;AGGREGAT(15;6;ZEILE(Ausgangstabelle!$B$1:$B$20)/(Ausgangstabelle!$B$1:$B$20=Zieltabelle!$B$1);ZEILE(B1)));"")
C4=WENNFEHLER(INDEX(Ausgangstabelle!D:D;AGGREGAT(15;6;ZEILE(Ausgangstabelle!$B$1:$B$20)/(Ausgangstabelle!$B$1:$B$20=Zieltabelle!$B$1);ZEILE(C1)));"")

ZelleGültigkeitstypOperatorWert1Wert2
B1Liste=$A$28:$A$30
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Hi,
 
mit ist erst jetzt aufgefallen, dass du Microsoft 365 benutzt. Dann geht es noch wesentlich einfacher:
Arbeitsblatt mit dem Namen 'Zieltabelle'
ABC
1SalesPeter
2
3KundeSendungBetrag
4ATest 18
5DTest 412
6ATest 9136

ZelleFormel
A4=FILTER(Ausgangstabelle!$A$1:$A$20;Ausgangstabelle!$B$1:$B$20=$B$1; "")
B4=FILTER(Ausgangstabelle!$C$1:$C$20;Ausgangstabelle!$B$1:$B$20=$B$1; "")
C4=FILTER(Ausgangstabelle!$D$1:$D$20;Ausgangstabelle!$B$1:$B$20=$B$1; "")

ZelleGültigkeitstypOperatorWert1Wert2
B1Liste=$A$28:$A$30
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
 
Der Vorteil: du musst jeweils nur eine einzige Formel eingeben; der Rest wird von Excel selbst erledigt.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • schauan
Antwortento top
#6
Grandios - in Qualität und Zeit. Vielen herzlichen Dank für die Unterstützung.  35
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste