Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

WENN DANN mit Textinhalten
#1
Hallo zusammen,

gerade in euer Forum reingestolpert und schon ne Frage – hab zwar hier im Forum gesucht, aber bei 225 Ergebnis-Seiten hat mein Hirn ein Reset durchgeführt… Daher versuch ich mal mein Glück direkt.

Also: Ich arbeite nicht sonderlich oft in Excel, hab aber eine Zeiterfassungs-Tabelle in die Hand bekommen, in der ich Kurzarbeit-Zeiten eintragen soll/darf/kann. Ist für einen besseren persönlichen Überblick gedacht.
Da mir die Tabelle nicht wirklich gut gefällt und nur für den aktuellen Monat gilt, war ich am überlegen, wie man die ggf. pimpen kann.

Folgendes Szenario:

1. Zeile: Wochentag =TEXT(A2;"TTT") Bezieht sich auf die 2. Zeile
2. Zeile: Datum (Bsp. 01.05.) Jahreszahl brauche ich nicht.
3. Zeile: Stunden pro Tag. Hier möchte ich gerne eine Abfrage (WENN ODER) als Funktion hinterlegen, die mir das Feld in A1 abfragt nach den Inhalten.

Also wenn A1="Mo", "Di", "Mi" oder "Do" dann 8. Wenn "Fr", dann 7. Ansonsten ""

Hab mir bisher diese Funktion irgendwie zusammengebastelt: =WENN(ODER(TEXT(A1)="Mo";TEXT(A1)="Di";TEXT(A1)="Mi";TEXT(A1)="Do");8;"")
Aber ich bekomme ständig diese Meldung:

Mit dieser Formel gibt es ein Problem.
Sie möchten gar keine Formel eingeben?

Wenn das erste Zeichen ein Gleichheitszeichen (=) oder Minuszeichen (-) ist, hält Excel Ihre Eingabe für eine Formel:
• Sie geben "=1+1" ein, und die Zelle zeigt: "2" an.
Um dieses Problem zu vermeiden, geben Sie zuerst ein Apostroph ( ' ) ein:
• Sie geben "'=1+1" ein, und die Zelle zeigt "=1+1" an.

Hat jemand von euch Profis ne Idee, warum das nicht funktionieren will?

Vorab schon mal Danke für eure Antworten…

Herzliche Grüße
Ralf
Antwortento top
#2
Hallo Ralf,

schreib es so:
Arbeitsblatt mit dem Namen 'Tabelle2'
AB
101. Mai6
205. Mai8
308. Mai6

ZelleFormel
B1=WENN(WOCHENTAG(A1;2)<=4;8;6)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Achte darauf, dass die Daten als Zahlen und nicht als Text formatiert sind.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
Hallo, wenn in A1 ein richtiges Datum steht..:

PHP-Code:
=VERWEIS(WOCHENTAG(A1;2);{1.5.6};{8.7.""}) 

oder ..:

PHP-Code:
=VERWEIS(REST(A1;7);{0.2.6};{"".8.7}) 

Hi Günter, hier sind aber die WE's mit 6 (Std.) noch drin... Ich glaub' das soll nicht...
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#4
Wow…

Das ging ja flott… Vielen Dank für eure Antworten…

@WillWissen: gestestet, funktioniert soweit, zeigt mir aber fürs Wochenende auch 8 Std. an.

@Jockel: das is abgefahren… Ich verstehs zwar nicht so richtig, aber es funktioniert. Add-on: Gäbe es hier noch eine Möglichkeit einer Abfrage, wenn in einem Bemerkungsfeld unter dem jeweiligen Datum ein F (für Feiertag) oder ein U (für Urlaub) steht, dass das Feld dann dort auch leer bleibt? Oder ist das dann zu viel Aufwand?

Ach und noch eine Frage zu den PHP-Elementen: kann man in der letzten {} auch auf Zellen in der Excel verweisen? Also wenn ich z.B. ne Matrix hinterlege für z.B. Mo 8, Di 4, Mi 8, Do 8, Fr 7 (jeder Std.-wert in einer eigenen Zelle)…?

Bin sehr dankbar für eure Hilfe…
Antwortento top
#5
Hallo, zeig' das doch mal bitte anhand (d)einer (Beispiel)Datei ... (d)einer Excel-Datei.
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#6
Sorry… Ganz in Gedanken gewesen…

Also ich stells mir so vor, wie im Anhang. Oder brauchst Du noch andere Inhalte (Funktionen, Formeln, o.ä.)?


Angehängte Dateien Thumbnail(s)
   

.xlsx   Kurzarbeit_Excel.xlsx (Größe: 11,06 KB / Downloads: 7)
Antwortento top
#7
Hallo, meinst du so..?

PHP-Code:
=WENN(B8<>"";"";VERWEIS(WOCHENTAG(B7;2);{1.5.6};{8.7.""})) 

oder so..?

Arbeitsblatt mit dem Namen 'Tabelle1'
BCDEFGHI
6FrSaSoMoDiMiDoFr
701.05.02.05.03.05.04.05.05.05.06.05.07.05.08.05.
8F
984887

ZelleFormel
B9=WENN(B8<>"";"";WENNFEHLER(INDEX($K$2:$O$2;;WOCHENTAG(B7;2));""))
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#8
Thumbs Up 
Großartig… Chapeau! Genau so. Vielen, vielen Dank…
Antwortento top
#9
Hallo @Jörg,

ich hoffe, ich bin nicht unverschämt mit der Frage, aber ist es machbar, die Wochenbelegung, die man ganz oben eingibt, in Deiner PHP-Formel anzusprechen/abzufragen?
Dann könnte man ggf. bei Veränderung der Wochenarbeitszeit einfach die Std. hier angeben, ohne Einfluss auf Deine Formel nehmen zu müssen.

Bin immer noch mega-begeistert über Deine Hilfe. 23

Herzliche Grüße
Ralf


Angehängte Dateien Thumbnail(s)
       
Antwortento top
#10
Hallo, das geht doch hiermit..:

PHP-Code:
=WENN(B8<>"";"";WENNFEHLER(INDEX($K$2:$O$2;;WOCHENTAG(B7;2));"")) 

Oder verstehe ich deine Frage nicht...?

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEFGHIJKLMNOPQRSTUVWXYZAAABACADAEAF
1Kurzarbeit in %40Wochenstunden regulär39Stundenverteilung (Mo, Di, Mi, Do, Fr)
2KA Arbeitszeit in %60Wochenstunden Kurzarbeit23,481247
3
4
5Mai 2020
6TagFrSaSoMoDiMiDoFrSaSoMoDiMiDoFrSaSoMoDiMiDoFrSaSoMoDiMiDoFrSaSo
7Datum01.05.02.05.03.05.04.05.05.05.06.05.07.05.08.05.09.05.10.05.11.05.12.05.13.05.14.05.15.05.16.05.17.05.18.05.19.05.20.05.21.05.22.05.23.05.24.05.25.05.26.05.27.05.28.05.29.05.30.05.31.05.
8BemerkungFFUUUUUU
9Regulär8124781247812
10Aktuell

ZelleFormel
B9=WENN(B8<>"";"";WENNFEHLER(INDEX($K$2:$O$2;;WOCHENTAG(B7;2));""))
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste