Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Sverweis nach Monat und Jahr suchen lassen
#1
Guten Abend,
ich würde mich freuen, wenn mir jemand mit folgender Formel behilflich sein könnte:
=WENNFEHLER(SVERWEIS(UND(MONAT(Y3);JAHR(Y3));Datenblatt!$H$174:$I$181;2;FALSCH);0)
Was soll mit der Formel erreicht werden:
In Y3 steht ein Datum im Format DD/MM/JJ; Excel soll nun im Bereich Datenblatt!$H$174:$I$181 nach dem Feld suchen, bei dem der Monat und das Jahr mit dem aus Y3 übereinstimmt (in Datenblatt!$H$174:$h$181 stehen ebenfalls Daten im Format DD/MM/JJJJ) und dann den Wert in der 2 Spalte der Matrix ausgeben, wenn Monat und Jahr übereinstimmen. Wenn nicht, dann soll der Wert 0 sein (daher WENNFehler).
Die Formel funktioniert, wenn ich genau nach dem Datum suche:
=WENNFEHLER(SVERWEIS(N3;Datenblatt!$H$174:$I$181;2;FALSCH);0)
Da jedoch nicht der Tag entscheidend sein soll, sondern nur der Monat und das Jahr, müsste ich die Formel umbauen, was ich mit der obigen Formel versucht habe aber leider nicht funktioniert. Huh
Bitte aber nicht vorschlagen, ich soll in y3 einfach nur Monat und Jahr eingeben 32 
Für jede Form der Unterstützung schon einmal ganz herzlichen Dank im Voraus.
Antwortento top
#2
Na? Hast du es eilig, weil du crosspostest ohne gegenseitigen Verweis? Rufst du dir auch zwei Taxis, nur damit du schneller zum Ziel kommst?
Sei also zumindest so fair und setze in jedem Forum einen Link auf das jeweils andere, dann fühlen sich die Helfer auch nicht verschaukelt.
Schöne Grüße
Berni
[-] Folgende(r) 1 Benutzer sagt Danke an MisterBurns für diesen Beitrag:
  • Jockel
Antwortento top
#3
Sorry, ja ich muss die Tabelle bis morgen fertig bekommen, deshalb der Doppelpost. Wollte keinen verschaukeln oder verärgern. Mea Culpa
Hier der Link zum Office-Forum (falls dies erlaubt ist):
Post Office Forum
Antwortento top
#4
https://www.youtube.com/watch?v=iQUDierJwVU
Schöne Grüße
Berni
Antwortento top
#5
Hi,

dann zeig uns bitte eine anonymisierte Beispieltabelle (Aufbau muss dem deines Originals entsprechen; ein paar wenige, aber relevante Datensätze genügen). Bitte keine Bildchen!!

So geht das Hochladen: https://www.clever-excel-forum.de/Thread...ng-stellen
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#6
Das Video habe ich mir angesehen, da wird leider aber auch nicht erklärt, wie ich nach dem Monat und dem Jahr suchen kann.

Anbei die Beispieldatei mit der nicht funktionierenden Formel


Angehängte Dateien
.xlsx   Musterbeispiel.xlsx (Größe: 11,56 KB / Downloads: 2)
Antwortento top
#7
=WENNFEHLER(SVERWEIS(N3;Datenblatt!$H$174:$I$181;2;FALSCH);0)

wird zu

=WENNFEHLER(INDEX(Datenblatt!$I$174:$I$181;VERGLEICH(TEXT(N3;;"JJJJMM");INDEX(TEXT(Datenblatt!$H$174:$H$181;"JJJJMM");););)
Antwortento top
#8
Danke aber bei der Formel bekomme ich den Hinweis: Sie haben zu viele Argumente für diese Funktion eingegeben mit der Makierung bei dem ersten "JJJJMM".
Antwortento top
#9
H5: =WENNFEHLER(INDEX(Tabelle2!$C$2:$C$9;VERGLEICH(TEXT(H1;"JJJJMM");INDEX(TEXT(Tabelle2!$B$2:$B$9;"JJJJMM"););));)
[-] Folgende(r) 1 Benutzer sagt Danke an LCohen für diesen Beitrag:
  • stoffel7
Antwortento top
#10
Mit einer zusätzlichen Klammer bringt er zwar keinen Fehlerhinweis mehr aber er gibt auch den gesuchten Wert nicht aus.
Hab die vorgeschlagene Formel mal in die Mustertabelle eingefügt zur besseren Verdeutlichung.

Merke gerade, dass ich die fehlende Klammer falsch gesetzt habe, mit dem Vorschlag von Cohen funktioniert es nun. Herzlichen Dank


Angehängte Dateien
.xlsx   Musterbeispiel.xlsx (Größe: 11,61 KB / Downloads: 6)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste