Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

SVerweis Makro oder einfache Formel? Spalten durchsuchen
#1
Hallo zusammen.

Ich habe schon oft wirklich gute Hilfe bei Euch gefunden, aber diesesmal komme ich nihct ohne eigene Fragestellung weiter.

Ich habe folgende Aufgabe, die vermutlich mit Access am Besten zu lösen wäre, das habe ich aber nicht.

Die viel gestellte Frage, wie man einer Kundenliste anhand von PLZ das Bundesland zuordnen kann. 

folgendes habe ich inzwischen in meiner Arbeitsdatei

ein Tabellenblatt, ORIGINAL mit meinen rund 625 Zeilen, in Spalte Q sind die PLZ, in S soll das Bundesland ausgespuckt werden.
ein Tabellenblatt, PLZ, in dem jede PLZ genau einmal nur drin steht (spalte A) und das dazu gehörige Bundesland (spalte B oder 2)

der Auftrag heißt in Worten: nimm in ORIGINAL den wert in Q2, suchen den in PLZ Spalte A2-A8291 und schreibe den Wert daneben in ORIGINAL S2 

Ich habe es erstmals mit Makro versucht, tolles Forum sei dank, aber das ist mir noch fremd.
gebastelt hatte ich 

Option Explicit
Public Sub Main()
    Dim varRow As Variant
    varRow = Application.Match(Original.Range("q2").Value, plz.Columns(1), 0)
    If IsNumeric(varRow) Then
        plz.Cells(varRow, 2).Value = Otiginal.Range("S2").Value
    End If
End Sub



das gleiche nochmal mit dem Zählwert der Tabelle (4 und 5), aber das hat auch nicht geklappt '(und da da ständig neue Tabellen rein kommen, auch fehleranfällig)

mit SVerweis bekomme ich aber immer nen Bezugsfehler:
=SVERWEIS(ORIGINAL!$Q3;plz!A2:A8291;2;FALSCH)

kann mir jemand helfen?

ich fühle mich reichlich ratlos gerade...

danke und liebe Grüße
Antwortento top
#2
Moin,

ich denke, das könnte mit Formeln erschlagen werden. Dazu müsste ich aber eine Beispieldatei, die deinem Original gleicht, haben. Als Anhaltspunkt nenne ich mal INDEX/AGGREGAT() oder INDEX/VERGLEICH().

So geht's Hochladen: https://www.clever-excel-forum.de/Thread...ng-stellen Bitte keine Bildchen!!
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
Hallöchen,

nimm einfach den SVERWEIS.
Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEF
1PLZBundesland
207549Thüringen07549GeraThüringen
387435Bayern
ZelleFormatWert
A2000007549
ZelleFormel
F2=SVERWEIS(D2;A1:B3;2;FALSCH)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#4
Hallo,

du bekommst den Bezug Fehler, weil Du in Deiner Formel den Bereich aus einer Spalte angibst aber den Wert aus der zweiten Spalte des Bereichs haben möchtest.

Deine Formel sollte so funktionieren:

=SVERWEIS(ORIGINAL!$Q3;plz!A2:B8291;2;FALSCH)

Wobei ich bei SVERWEIS() den Bereich absolut setzen würde

=SVERWEIS(ORIGINAL!$Q3;plz!$A$2:$B$8291;2;FALSCH)
Gruß Atilla
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste