Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Kontrolle der Anzahl zwischen zwei verschiedenen Arbeitsmappen
#1
Ich hab in einer Arbeitsmappe eine laufende Nummer. Diese soll in einer anderen Arbeitsmappe genauso häufig vorkommen, wie in der ersten Arbeitsmappe daneben die Anzahl angeführt ist.


Also in etwa so:

A1:
Nr1   3
Nr2   2

A2:
Nr1
Nr1
Nr1
Nr2
Nr2


Nun hätte ich gerne in der zweiten Arbeitsmappe quasi eine "Live-Kontrolle, dass immer genau die Anzahl der in Arbeitsmappe zwei angeführten Einträge sind. Zum Beispiel eine Bedingte Formatierung, die mir die Spalte rot anzeigt, wenn die Anzahl aus dem Tabellenblatt nicht erfüllt ist. Leider scheitere ich dabei in der Umsetzung.

Ich vermute, dass ich die Funktion zählen und wenn benötigen werde, aber geht dies über eine andere Arbeitsmappe hinweg (in der selben Datei). 

Hat jemand einen Tip, wie ich das lösen kann?
Antwortento top
#2
Hola,

ungetestet:
als Formel in der bedingten Formatierung:
=zählenwenn($A$2:$A$100;A2)<>sverweis(A2;Tabelle1!A:B;2;0)

Gruß,
steve1da
Antwortento top
#3
(12.09.2020, 19:09)mcdutch schrieb: Ich vermute, dass ich die Funktion zählen und wenn benötigen werde, aber geht dies über eine andere Arbeitsmappe hinweg (in der selben Datei). 
Andere Arbeitsmappe in der selben Datei?
Klingt so wie mehrere Arme an einem Finger.

In der selben Mappe/Datei geht es mit ZÄHLENWENN().
Mappengreifend geht es nicht mit ZÄHLENWENN() - wenn die Quellmappe geschlossen ist.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#4
Ja, es ist in der selben datei.

Irgendiwe klappt das mit dem sverweis bei mir leider nicht.

Deshalb jetzt eine andere Idee. Ich mache eine Kontrollspalte in Tabelle 2. Nämlich so:


Arbeitsblatt1:
Spalte 1 Spalte 2  Spalte 3
Nr1       3        3(Anzahl aus A2)
Nr2       2        2 (Anzahl aus A2)

Arbeitsblatt2:
Spalte 1
Nr1 
Nr1
Nr1
Nr2
Nr2



Hätte dafür jetzt zählenwenn vorgesehen. Nämlich in Arbeitsblatt1 - Spalte 3-> =ZÄHLENWENN(Arbeitsblatt2!A2:M4922;A2)

Leider scheint das nicht zu funktionieren :(
Antwortento top
#5
Moin,

lad mal bitte eine Beispieldatei (.xlsx - keine Bildchen!) hoch. https://www.clever-excel-forum.de/Thread...ng-stellen
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#6
Ok, ich hoffe mit der Datei im Anhang ist es verständlicher. Also ich möchte kontrollieren, dass die Spalte Einlösenummer im  anderen Tablelenblatt genau die Anzahl wie die Anzahl im der Tabelle 2 angegeben hat.
Antwortento top
#7
Hola,

da ist kein Anhang.

Gruß,
steve1da
Antwortento top
#8
Sorry, bin noch nicht so lange hierSmile

Jetzt aber...


Angehängte Dateien
.xlsx   beispieldatei.xlsx (Größe: 10,06 KB / Downloads: 3)
Antwortento top
#9
Hola,

wenn die Beschreibung nicht zur wirklichen Datei passt, dann kann das auch nicht klappen....


Code:
=ZÄHLENWENN($B$2:$B$7;B2)<>INDEX(Tabelle2!$C$2:$C$4;VERGLEICH(B2;Tabelle2!$D$2:$D$4;0))

Gruß,
steve1da
Antwortento top
#10
Die Formel sieht zwar gut aus, aber in der Beispieldatei ist die Berechnung falsch. Irgendwie zeigt er immer nur richtig, wenn es zwei Werte sind.
Es scheint da noch ein wenig was falsch drinnen zu sein.

Ich tüftle mal daran.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste