Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Kalenderwoche dynamisch stundenberechnung
#1
Hallo

Die Ausgangssituation 

Ein dynamischer Kalender Arbeitszeitberechnung. Spalte 1 Datum, Spalte 2 Wochentag, 
Spalte 3 Kalenderwoche, 

   

Code:
=WENN(B8="";"";TEXT(KALENDERWOCHE(A8;21);"@"))

Spalte 4 Wahrheitsprüfung

Code:
=WENN(B8="Mo";WAHR)

In einem anderen Bereich lasse ich mit mit folgender Formel das Datum von bis anzeigen.

Code:
=TEXT(INDEX($A$8:$A$38;VERGLEICH($AH6&Berechnungshilfen!$K$1;$C$8:$C$38&$D$8:$D$38;0));"TT.MMM.JJJJ")&" bis "&TEXT(INDEX($A$8:$A$38;VERGLEICH($AH6&Berechnungshilfen!$K$1;$C$8:$C$38&$D$8:$D$38;0))+7;"TT.MMM.JJJJ")

Rechts daneben die Summe der Arbeitszeit nach Kalenderwoche mit (in Spalte I stehen Arbeitszeiten montag bis Freitag.)

Code:
=WENN(SUMMEWENNS($I$8:$I$38;$C$8:$C$38;AH6)=0;"";SUMMEWENNS($I$8:$I$38;$C$8:$C$38;AH6))

Zu meinem Problem.  Da ich in Spalte 4 die Wahrheitsprüfung für Montag habe, leider der 1. Im Monat immer ein anderer Wochentag ist. (monat/jahr). Wie gesagt. Dynamischer Jahreskalender.
Hat jemand eine Idee wie ich die wahrheitsprüfung Spalte 4 dynamisch hinbekomme?

   

Viel Dank schon mal

Auf dem 2. Screenshot AI6 #NV wird verursacht weil die wahrheitsprüfung nur auf montags fällt. Aber am 1. Des Monats eben nicht immer Montag steht...

Ich hoffe das war verstänflich
Antwortento top
#2
Hallöchen,

Zitat: Da ich in Spalte 4 die Wahrheitsprüfung für Montag habe, leider der 1. Im Monat immer ein anderer Wochentag ist.

Das Problem lässt sich nicht lösen, das ist nun mal so. Die Mayas hatten gleich lange 18 Monate mit 20 Tagen, da fingen die Monate immer mit dem gleichen Tag an Smile.
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#3
Na dann werde ich wohl damit leben müssen. Ich hätte gedacht ich kann die wahrheitsprüfung auf Basis des 1. Tages im monat durchführen.

=WENN(B8=Wochentag des 1. Des Monats;WAHR)

So hatte ich mir das gedacht.
Antwortento top
#4
Moin

Was soll denn das Ergebnis in AI6 und AK6 sein?
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#5
Hallo.

In AI6 soll das Datum von bin der Kalenderwoche stehen. AK6 kannst du ignorieren. Im Grunde ganz einfach. 1. Spalte Kalenderwoche, 2. Spalte Datum von bis ohne den Fehler # NV  in Zeile 6,  3. Spalte die summierte Wochenarbeitszeit.
Es soll das Datum vom 1. Des Monats bis zum Wochenende drin stehen.
Antwortento top
#6
(12.11.2020, 06:28)Heiko* schrieb: In AI6 soll das Datum von bin der Kalenderwoche stehen.
[...]
Es soll das Datum vom 1. Des Monats bis zum Wochenende drin stehen.
Okay, du weißt es also selber nicht.
Wenn du es dann irgendwann mal weißt kannst du dich ja noch mal melden.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#7
Hallöchen,

Zitat:Na dann werde ich wohl damit leben müssen. Ich hätte gedacht ich kann die wahrheitsprüfung auf Basis des 1. Tages im monat durchführen.

nein, musst Du nicht. So was geht auch. Nur habe ich es so nicht aus der Aufgabe herausgelesen und so ganz klar ist das auch noch nicht. Wenn Du wissen willst, ob ein Datum der Monatsanfang ist, sollte dort für den Tag eine 1 stehen.

Wenn Du über den Monat prüfen willst, ob ein Tag der gleiche Wochentag ist wie am 1., dann z.B. so

Arbeitsblatt mit dem Namen 'Tabelle1'
AB
101. JanWAHR
202. JanFALSCH
303. JanFALSCH
404. JanFALSCH
505. JanFALSCH
606. JanFALSCH
707. JanFALSCH
808. JanWAHR
909. JanFALSCH
1010. JanFALSCH
1111. JanFALSCH

ZelleFormel
B1=(WOCHENTAG(DATUM(JAHR(A1);MONAT(A1);1))=WOCHENTAG(A1))
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#8
Danke.
Antwortento top
#9
Da hab ich nun doch alles neu gemacht. Und viel einfacher. Trotzdem danke für den kleinen Denkanstoß.

Zur Erinnerung

Ich habe meine dynamische Arbeitszeitberechnung. 12 Tabellenblätter Januar bis Dezember
1 Blatt zur Übersicht und eins für hilfsberechnungen. In Spalte A Datum 1. Bis 30/31. Spalte G Stunden pro Tag mit leeren Zellen an Wochenenden. Spalte Q sind Kalenderwoche. 
Das ganze ist auf den 12 Blättern Januar bis Dezember identisch.

Ich möchte mir jetzt auf meiner Übersicht die Kalenderwoche mit dazugehörigen summierten Stunden der jeweiligen Arbeitswoche anzeigen.

Dazu habe ich die KW untereinanderstehen. Rechts daneben wollte ich mit summewenns
die summen der Arbeitswoche berechnen lassen. Ein Monat bekomm ich hin..

=SUMMEWENNS(Januar!$G$8:$G$38;Januar!$Q$8:$Q$38;P1)

Aber beim Versuch die summen der restlichen Monate zu bilden scheitere ich kläglich...

=SUMMEWENNS(INDIREKT(I23&"!G8:G38");INDIREKT(I23&"!Q8:Q38");P1)

Hier stehen in I23 bis I34 die Monatsnamen. Bereiche der einzelnen Monate sind benannt.

Kann mir jemand helfen? Ich wollte deshalb nichts neues aufmachen.

Vielen Dank
HEIKO*
Antwortento top
#10
Hallo Heiko,

eine Beispieldatei hilft helfen.
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste