Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Fortlaufende +/- 1 Berechnung
#1
Moin,

leider weiß ich mir (abgesehen von einer extra Spalte wo die jeweilige Nummer steht) keine Abhilfe.

Einfaches Problem. Ich habe eine Formel.

Z.B.

A1 ------------- =SUMME(B$1$:B$10$)-5

jetzt möchte ich diese Formel quasi runterziehen. Dann steht in A2.

A2 ------------- =SUMME(B$1$:B$10$)-5

Ich möchte die "-5" aber pro Zeile die ich die Formel runterziehe -1 rechnen.

D.h. in A2 würde -5-1 in A3 -5-1-1 in A4 -5-1-1-1 usw stehen. Wie bekomme ich das jetzt in eine Formel gepackt, dass ich sich pro Zeile immer -1 dazu bekomme.
Antwortento top
#2
Hallo,

=SUMME($B$1:$B$10)-(ZEILE()+4)

Gruß Werner
Antwortento top
#3
Moin!
Einfacher dürfte ab A2 sein:
=A1-1
herunterziehen.

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#4
RPP63 hat insofern recht, als dass er den Berechnungsoverkill wiederholter Formeln unterlässt, den Werner nicht beachtet.

A2: =-5+1-ZEILE()

A2: =-5-ZEILE(A1)

A2: =-ZEILE(A6)
Antwortento top
#5
Noch eine Variante ohne (zusätzliche) Formeln:
  • Deine Formel in A1
  • A1 markieren
  • im Namenfeld An eingeben, wobei n die letzte Zelle der Reihe ist, also z.B. A199
  • bei gedrückter Umschalttaste Enter drücken
  • Start, Bearbeiten, Ausfüllen, Datenreihe
  • als Inkrement -1 eingeben
Fertig!
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#6
Moin, danke für eure Beiträge! Ich habe gerade gesehen, dass ich es euch glaube ich falsch erklärt habe. Es geht nämlich um eine Aggregat/Index Funktion.

Da steht am Ende dann ;zeile()-100
wenn ich dann unter die Zeile die gleiche Funktion eingebe, muss ich dort -101 schreiben, da sich ja leider der Bezug der Zelle geändert hat.

https://www.youtube.com/watch?v=He3dblboncw

ab der 8 Minute erklärt er es.

Sobald man in Zeile 7 ist, muss man -6 schreiben. Wenn man das ganze dann runter zieht muss sich die Zeile ja ändern
Antwortento top
#7
Hi,

hast Du Formeln überhaupt mal ausprobiert, wenn Du sie schon nicht verstehst?
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#8
Hi,

ich hab' mir das Video jetzt nicht angesehen; nach deiner Beschreibung
Zitat:Wenn man das ganze dann runter zieht muss sich die Zeile ja ändern
geh ich aber davon aus, dass du die INDEX/AGGREGAT()-Fkt. so meinst (der normal gefärbte Teil ist beispielhaft, der farbige betrifft deine Anfrage):
Zitat:=INDEX(B:B;AGGREGAT(15;6;ZEILE($A$1:$A$15)/($A$1:$A$15="A")/($C$1:$C$15="X");ZEILE()-6))
Beginn der Tabelle ist in diesem Beispiel in Zeile 7
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#9
@WillWissen, das ist korrekt!

@Bosko, ja wenn ich die Formel runterziehe, dann steht da "Wert". Leider lässt sie sich nicht runterziehen, oder ich bin zu doof dafür.

Ich möchte mit dem runterziehen, ja auch immer Bezug auf 1-2 neue Werte in der nächsten Zeile nehmen.

Also A7 und B7 stehen 2 Werte. C7 die Formel mit -6 als Zeile.
In A8 und B8 stehen 2 neue Werte. In C8 soll dann die runtergezogene Formel mit -7 stehen, welche Bezug auf A8 und B8 nehmen.

Das ist mein Problem

=WENNFEHLER(INDEX(E:E;AGGREGAT(15;6;ZEILE(A:A)/(FINDEN(A1862;A:A;1)>0);ZEILE()-1861);1);""))

Aktuell sieht das so aus..
Antwortento top
#10
Hallo,

zeig mal bitte eine Beispieldatei (Daten anonymisiert, Aufbau identisch deinem Original) mit händisch eingetragenen Wunschergebnissen. Keine Bildchen!! https://www.clever-excel-forum.de/Thread...ng-stellen
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste