Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Excel-Datenbank, automatische Übernahme von Änderungen in den anderen Reitern
#1
Hallo zusammen und einen schönen guten Abend.
Ich weiss nicht mehr weiter mit meiner Exel-Datenbank und würde mich freuen, wenn ich hier den einen oder anderen Tip bekomme, wie ich meine Arbeitsabläufe minimieren kann. Folgendes:
Ich verwalte Personaldaten von über 700 Personen in einem Verein. Ich habe alle Daten in eine Excel-Datei importiert. Name, Anschrift, Geburtsdatum usw usw usw. In der gleichen Exceldatei habe ich weitere Reiter eingerichtet, um den Gesamtbestand in Gruppen einzuteilen. Wenn ich nun im 1 Reiter irgend eine Änderung vornehme, dann musste ich bislang in jedem Unterreiter diese Änderung ebenfalls vornehmen. Wie kann ich meine Excelliste so gestalten, dass, wenn ich im ersten Datenblatt etwas ändere, dass diese Änderung automatisch in den anderen Reitern automatisch übernommen wird?

Ich bedanke mich schon jetzt einmal für die lieben und vielen Antworten.


MfG
Antwortento top
#2
Hallo Christian,

du solltest uns eine .xlsx mit anonymisierten Daten zur Verfügung stellen. Es reichen etwa 15 Datensätze; der Aufbau der Beispieldatei muss aber deinem Original gleichen. https://www.clever-excel-forum.de/Thread...ng-stellen
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • Christian64
Antwortento top
#3
(14.07.2020, 19:31)Christian64 schrieb: In der gleichen Exceldatei habe ich weitere Reiter eingerichtet, um den Gesamtbestand in Gruppen einzuteilen.
Du benötigst dafür keine weiteren Tabellenblätter.
Filter oder Datenschnitt auf die Originaltabelle reicht.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#4
.....so, habe hier mal eine kleine Datei erstellt.
Antwortento top
#5
Hi Christian,

folge mal dem roten Pfeil. Da ist noch ein Button, der gerne gedrückt werden will. Wink
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#6
Hi,
du musst noch rechts auf "Attachement hinzufügen" klicken.
Cadmus
Antwortento top
#7

.xls   Kompanie-Mitgliederliste Juli 2020-Kopie.xls (Größe: 234,5 KB / Downloads: 11) .....sorry, ja, da war was. Hatte das gestern kurz auf der Arbeit gemacht. War gestern viel los bei uns.

So, jetzt noch einmal mit Tabelle und ich hoffe, dass das jetzt geklappt hat.

Und vielen Dank noch einmal für eure tolle Unterstützung


Gruß Christian

.....ihr seht, dass ich hier schon die eine und andere Formel hinterlegt habe.

jetzt ist es so, dass ich meine Liste in der Form konfiguriert haben möchte, dass, wenn ich zB im 1. Reiter eine Adressenänderung habe, diese dann in den anderen Reitern automatisch übernommen wird
Antwortento top
#8
Hallo Christian,

mein Vorschlag mal nur für den 1. Zug (und hier nur bis zum Geburtsdatum):
Arbeitsblatt mit dem Namen '1. Zug'
ABCDE
30101004mWolfgangI07.08.1953
31105027mPeterJ04.03.1964
32201007mMarkusK19.05.1981
33800063mChristianL13.09.1982
34800103mMarkusM21.01.1976

ZelleFormel
A30=WENNFEHLER(INDEX(Kompanie!A:A;AGGREGAT(15;6;ZEILE(Kompanie!$A$30:$A$42)/(Kompanie!$F$30:$F$42="1. Zug");ZEILE(A1)));"")
B30=WENNFEHLER(SVERWEIS($A30;Kompanie!$A$30:$S$50;SPALTE(B$1);0);"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Voraussetzung für das Funktionieren meines Vorschlages ist, dass du im Blatt Kompanie eine Spalte ein- oder anfügst, in der du du die Zugzugehörigkeit einträgst. Dann kannst du die Mitgliedsnummern mit INDEX/AGGREGAT() automatisch eintragen und über diese mit einem SVERWEIS() die zugehörigen Daten holen. Damit du die Formel nach rechts (und natürlich nach unten) ziehen kannst, müssen die Spalten in allen Blättern identisch sein!!

Wieso hast du eine .xls bei Excel 2016? Das ist ein altes Format, mit dem du nur runde 65 Tsd Zeilen und 256 Spalten bekommst. Ab XL 2007 ist das Format .xlsx mit 1,4 Mio Zeilen und über 16 Tsd Spalten.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#9
Hallo Günter.......,

erst einmal vielen Dank für deine schnelle Antwort. Ja, Excel müsste ich mal aktualisieren, werde ich die Tage mal machen.
Ich werde mich mal gleich mit deiner Formel auseinandersetzen und schauen, ob ich dass so hin bekomme. Da würde bedeuten,
dass alle Reiter den gleichen Inhalt haben müssen. Geht das auch, wenn ich z.B. dann im 1. Zug einige Zeilen ausblende, dass
#letzendlich auch nur die Mitglieder im 1. Zug zu sehen sind? Das könnte man ja im Filter ja machen.


Gruß
Antwortento top
#10
Hi Christian,


Zitat:Geht das auch, wenn ich z.B. dann im 1. Zug einige Zeilen ausblende, dass

#letzendlich auch nur die Mitglieder im 1. Zug zu sehen sind? Das könnte man ja im Filter ja machen.
Im Blatt 1. Zug tauchen ausschließlich die Mitglieder auf, die du im Blatt Kompanie dafür vorgesehen hast (deshalb die zusätzliche Spalte).
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste