Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Abgleich Anzahl verschiedener gewählter Nummern
#1
Hallo Zusammen,

ich habe einen CRM Ecpprt eine Excel Tabelle in der in einer Liste aufgeführt ist,
welcher Mitarbeiter an welchen Tagen welche Rufnummern gewählt hat.

Über die ZÄHLENWENNS FUNKTION kann ich problemlos zählen, wieviele Anrufe jeder Mitarbeiter je Tag durchgeführt hat.

Allerdings würde ich auch gerne auswerten, wieviele verschiedene Rufnummern ein Mitarbeiter an einem bestimmten Tag angewählt hat.

So ist die Liste aufgebaut...
Datum - Mitarbeiter - gewählte Rufnummer

Hat jemand einen Tipp für mich, wie ich das machen kann?

Besten Dank schonmalSmile
Antwortento top
#2
Hola,

https://www.herber.de/excelformeln/pages...ungen.html

Gruß,
steve1da
Antwortento top
#3
Hallo,

nimm SUMMENPRODUKT().
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#4
Danke dir!

Allerdings habe ich zwei Bedingungen, die zutreffen müssen:

Es sollen alle unterschiedlichen Eintragungen in Spalte C gezählt werden, die in Spalte A den Wert X haben und in Spalte B den Wert Y.

Das haut mit der Formel aus deinem Link nicht hin, oder?
Antwortento top
#5
Hola,

doch, auch das haut hin. In der Summenprodukt-Formel


Code:
=SUMMENPRODUKT((VERGLEICH(A1:A10&B1:B10;A1:A10&B1:B10;0)=ZEILE(X1:X10))*(A1:A10=4)*(B1:B10<>""))

kommt der zusätzliche Bereich in den Vergleich-Teil und die Bedingung ebenso.


Code:
=SUMMENPRODUKT((VERGLEICH(A1:A10&B1:B10&C1:C10;A1:A10&B1:B10&C1:C10;0)=ZEILE(X1:X10))*(A1:A10="x")*(C1:C10="y")*(B1:B10<>""))

Gruß,
steve1da
Antwortento top
#6
Hallo,

deine Frage sagt mir, dass du angebotene Lösungen gar nicht ausprobierst. Sad  Und: mit einer Beispieldatei, die vom Aufbau her deinem Original entsprechen muss, können die Helfer gezielter antworten. https://www.clever-excel-forum.de/Thread...ng-stellen
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#7
Ok, ich probiere es gleich mal aus, danke nochmalSmile

(28.07.2020, 15:33)WillWissen schrieb: Hallo,

deine Frage sagt mir, dass du angebotene Lösungen gar nicht ausprobierst. Sad  Und: mit einer Beispieldatei, die vom Aufbau her deinem Original entsprechen muss, können die Helfer gezielter antworten. https://www.clever-excel-forum.de/Thread...ng-stellen

hey, danke für den Hinweis.
meine o,g, Antwort war eher nochmal als Verständnisfrage gemeint und auch nicht auf deine erste Antwort bezogen.

ich probiere mich jetzt mal aus und komme im Zweifel nochmal mit einem Beispieldokument im die Ecke, falls ich es nicht hinbekomme.

danke auf jeden Fall für den Support
Antwortento top
#8
Habs leider nicht hinbekommen :(:(



Ich habe jetzt mal eine Beispieltabelle angelegt und Screenshots von den betroffenen Reitern gemacht.

In Reiter 1 sind die Rohdaten.

In Reiter 2 die Auswertung.
--> Hier soll das Datumsfeld manuell geändert werden können.
--> Zeile 4: Hier sollen die Anzahl der verschiedenen Rufnummern stehen, die der Mitarbeiter (Zeile 2) an dem jeweiligen Tag (Zeile 1) angewählt hat (Informationen stehen im Reiter 1)

Vielen Dank für die Unterstützung, bin schon für die ersten Antworten sehr dankbar und hätte nicht gedacht, dass das hier so schnell gehtSmile


Angehängte Dateien Thumbnail(s)
       

.xlsx   Test Auswertung Anrufe.xlsx (Größe: 6,69 KB / Downloads: 5)
Antwortento top
#9
Hi,

mal ein Vorschlag mit einer (ausblendbaren) Hilfsspalte im Blatt Anruflisten:

Arbeitsblatt mit dem Namen 'Anruflisten'
ABCD
1DatumMitarbeiterTelefonnummerHS
227.07.2020Hans+49123721
327.07.2020Peter+41938391
427.07.2020Julia+4998267331
527.07.2020Hans+49123722
627.07.2020Hans+49873878491
727.07.2020Julia+49934441
827.07.2020Hans+434343431
927.07.2020Julia+83792831
1027.07.2020Peter+49934442

ZelleFormel
D2=ZÄHLENWENN($C$2:$C2;$C2)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Arbeitsblatt mit dem Namen 'Auswertung'
ABCD
1Datum27.07.202028.07.202028.07.2020
2MitarbeiterHansPeterJulia
3Anzahl Anrufe400
4Anzahl versch. Rufnummern300

ZelleFormel
B3=ZÄHLENWENNS(Anruflisten!$B$1:$B$20;B$2;Anruflisten!$A$1:$A$20;B$1)
B4=ZÄHLENWENNS(Anruflisten!$D$1:$D$20;1;Anruflisten!$B$1:$B$20;B$2;Anruflisten!$A$1:$A$20;B$1)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#10
Hola,

die Formel aus dem Link, angepasst auf deine Datei:

Code:
=SUMMENPRODUKT((VERGLEICH(Anruflisten!$A$2:$A$10&Anruflisten!$C$2:$C$10&Anruflisten!$B$2:$B$10;Anruflisten!$A$2:$A$10&Anruflisten!$C$2:$C$10&Anruflisten!$B$2:$B$10;0)=ZEILE($X$2:$X$10)-1)*(Anruflisten!$A$2:$A$10=B1)*(Anruflisten!$B$2:$B$10=B2)*(Anruflisten!$C$2:$C$10<>""))

Wird aber überall 0 ergeben weil das Datum nicht passt. Außerdem hat Hans nicht 4 unterschiedliche Nummern gewählt, sondern nur 3.

Gruß,
steve1da
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste