Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

3 Zellen für 1 Berechnung
#1
Hallo Excel Profis,

ich habe da so ein Problem:

Ich muß Spritkosten berechnen.
Die Spritkosten werden in 3 verschiedene Formate angegeben:
- $/Ltr.
- $ USD (US Gallone)
- $/MT (Metric Ton)

Ich muß jetzt ein Formular entwickeln, in dem beliebig $/Ltr.,$/USG oder $/MT eingegeben werden kann. Resultat soll dann immer $/Kg sein.

Ich wurde gerne in:
A2   $/Ltr.
B2   $ USD
C2   $/MT

den $ Wert eingeben, und dann spuckt mir D2 den $/Kg raus. (umrechnungsformel kann ich).

Wichtig dabei ist, dass wenn ich 2 oder sogar 3 Angaben gleichzeitig mache, dass in D2 eine "Fehlermeldung" erscheint. Dann ist nämlich gesichert, dass zumindes keine doppelten Angaben erfolgen.
Gut wäre es auch, wenn keine eingabe erfolgt ist, dass die Zelle D2 ganz leer ist, also auch keine 0 (null).

Wer kann das ?

Vielen herzlichen Dank.

Beste Grüße,
KD
Antwortento top
#2
Hallo KDM,


Zitat:Wer kann das ?
du!!! Mit unserer Hilfe. Dazu solltest du uns eine Beispieldatei mit deinen bisherigen Bemühungen vorstellen. So geht's: https://www.clever-excel-forum.de/Thread...ng-stellen
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
Hi Günter,

angefügt ist das Beispiel.

Aber das ist so leer, ich Traue es mir fast gar nicht anhängen.
Das problem ist I kann keine Formel für die Spritumrechung anhängen, weil sie ja alle in D2 das Ergebnis darstellen sollen.

Vielen Dank im voraus.

Best Grüße
KD


Angehängte Dateien
.xlsx   Spritberechnung.xlsx (Größe: 8,59 KB / Downloads: 6)
Antwortento top
#4
Moin

Code:
=WENN(ANZAHL(A5:C5)>1;"Du hast Blödsinn eingegeben!";Umrechnungsformel)
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#5
Hi,


Zitat:den $ Wert eingeben, und dann spuckt mir D2 den $/Kg raus. (umrechnungsformel kann ich).


und warum kannst du uns die Formel nicht sagen? Ist sie so geheim? Es wäre auch hilfreich gewesen, wenn du zusätzlich ein paar Wunschergebnisse eingetragen hättest (händisch).
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#6
Hi Günter,

nein das ist natürlich kein geheimniss and so einfach, dass ich es gar nicht zeigen wollte.

Was ich aber nicht kann ist diese formeln alle in D2 vereinen

Nochmal Danke Smile


KD


Angehängte Dateien
.xlsx   Spritberechnung.xlsx (Größe: 9,07 KB / Downloads: 6)
Antwortento top
#7
Wenn ich
Code:
=SUMME(A5/0,8)
lese, rollen sich mir echt die Zehennägel rückwärts auf Confused 22 

Code:
=WENN(ANZAHL(A5:C5)>1;"Du hast Blödsinn eingegeben";A5/0,8+B5/3,85*0,8*C5/1000)
Schöne Grüße
Berni
Antwortento top
#8
Mister Burns, du meinst sicher:

Code:
=WENN(ANZAHL(A5:C5)>1;"Du hast Blödsinn eingegeben";SUMME(A5/0,8+B5/3,85*0,8*C5/1000))
Ohne SUMME() ist die Formel nur halb so gut.
Angel
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#9
Also das funktoniert irgendwie nicht.

Anbei nochmal die Tabelle.

Wenn ich eine Eingabe in $/Ltr. mache (also A2) rechnet die Formel richtig.

Sobald ich in B2 was eingebe, kommt die Fehlermeldung, auch noch richtig. Wenn ich aber jetzt A2 lösche wird die Angabe in B2 ($/USG) nicht umgerechnet und in D2 erscheine $0.
Das gleiche für C2

Any Lösung ?

Vielen Dank


Angehängte Dateien
.xlsx   Spritberechnung.xlsx (Größe: 8,99 KB / Downloads: 5)
Antwortento top
#10
Wie wäre es denn damit?
Code:
=WENN(ANZAHL(A5:C5)>1;"Du hast Blödsinn eingegeben!";MAX(A5/0,8+B5/3,85*0,8+C5/1000))
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste