Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

2 Wenn Formeln in einer Zelle Addieren
#1
Question 
Guten Morgen, 


bisher habe ich immer eine Lösung hier gefunden, für dieses Problem bin ich jedoch nicht fündig geworden und hoffe auf eure Unterstützung. 

Meine Formel sieht folgendermaßen aus: 

=SUMME((WENN(D3<50;ComboBox!D2;ComboBox!D3));(WENN(F3="Ja";5;0)))

Das teilt sich in 2 Schritte auf: 

Schritt 1: 
WENN(D3<50;ComboBox!D2;ComboBox!D3)
Hier wird geprüft ob das Alter, dass in Zelle D3 eingetragen ist größer oder kleiner als 50 Jahre ist. Wenn es kleiner als 50 ist, wird aus einem anderen Tabellenblatt die entsprechenden Urlaubstage eingetragen. 

Schritt 2: 
Hier wird geprüft ob in der Spalte Behinderung "Ja" steht, sofern dass der Fall ist, sollen 5 weitere Tage Urlaub addiert werden. 

Das Ergebnis meiner Formel ist jedoch immer nur das Ergebnis aus Schritt 1, Schritt 2 wird offensichtlich nicht berücksichtigt. Ich habe es auch schon mit einer lokalen Office Version mit Strg-Shift-Enter als Matrixformel versucht, jedoch ebenfalls ohne Erfolg. 

Hat jemand dazu eine Idee? Soll ich mal Screenshots posten oder könnt ihr es euch so vorstellen?
Antwortento top
#2
Moin,

stell bitte eine Beispieldatei zur Verfügung; die wenigsten Helfer sind bereit, eine solche nach Bildchen oder nach Beschreibungen anzulegen. So geht's: https://www.clever-excel-forum.de/Thread...ng-stellen
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
Hola,

paar Klammern zuviel aber deine Formel macht was sie soll.
Bei mir wird Schritt 2 ebenfalls berücksichtigt.

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • noobi
Antwortento top
#4
Hallo,

aus dem Bauch raus ist Summe nicht erforderlich.

=WENN(D3<50;ComboBox!D2;ComboBox!D3)+WENN(F3="Ja";5;0)
Cadmus
Antwortento top
#5
Ui, das geht ja schnell mit den Rückmeldungen... 

Habe jetzt auch festgestellt woran es liegt. Die Formel funktioniert wenn ich das "Ja" händisch eintippe, wenn ich das "Ja" aber aus dem Dropdown auswähle passiert nichts... 

Woran kann das liegen?
Antwortento top
#6
Hola,

das "ja" im Dropdown hat bestimmt ein Leerzeichen hinten dran.

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • noobi
Antwortento top
#7
Peinlich...  16

Danke für eure Hilfe und das in Rekordzeit. Geniales Forum  100
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste