Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Formel anpassen! Gewichtskontrolle - BMI
#1
Hallo!

Ich habe mir eigene Gewichtskontrollen Tabelle Gebastelt:
Wie kann ich diese Formel:
=WENN(E5<21;"Untergewicht";WENN(E5>26;"Übergewicht";"Normalgewicht"))

so anpassen das die Spalte D erst mal Leer bleibt, bis in Spalte E ein Wert angegeben ist.


Betreff erweitert!
Moderator
?mage


Angehängte Dateien
.xlsx   Gewichtskontrolle-Test.xlsx (Größe: 17,43 KB / Downloads: 13)
Gruß
eddy
to top
#2
Hallo,

Kann ich zwar im Moment nicht testen, aber versuche es mal so:
=wenn(e5<>"";deine Formel;"")

Gruß
Marcus

Ich arbeite mit Excel 2003!

Wissen ist Macht - es ist aber nicht schlimm nicht alles zu wissen.
Man muss nicht alles wissen - man muss nur wissen wo es steht, oder wo man Hilfe bekommt.


?mage
to top
#3
Hallo

Code:
=VERWEIS(E5;{0;21;26};{"Unter";"Normal";"Über"})&"gewicht"
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
to top
#4
Hallo Detlef,

Dein Beitrag beantwortet aber nicht die Frage von eddy. ;-)

Gruß Uwe
to top
#5
Zitat:Dein Beitrag beantwortet aber nicht die Frage von eddy. ;-)
Okay...
Kleine Anpassung.
Code:
=VERWEIS(E5;{0;1;21;26};{"";"Untergewicht";"Normalgewicht";"Übergewicht"})
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
to top
#6
@marose67
Geht leider nicht.

@shift-del

Habe mal den zweiten Vorschlag ausprobiert, und die Formel funktioniert auch, echt super!

Vielen Dank an alle!
Gruß
eddy
to top
#7
Leider ist es aber so dass wenn jetzt überhaupt keine Angaben in der Tabelle stehen, auch nicht bei Spalte A und B das dann in Spalte D und E in den Zellen folgendes steht #DIV/0!
Gruß
eddy
to top
#8
Das kann ich nicht nachvollziehen.
Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDE
10     

ZelleFormel
C10=WENN(B10<>"";B10-B9;"")
D10=VERWEIS(E10;{0;1;21;26};{"";"Untergewicht";"Normalgewicht";"Übergewicht"})
E10=B10/$B$2^2
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
to top
#9
Wenn ich aus der Tabelle die Größen Angabe aus B2 (1.67m) entferne habe ich das besagte Ergebnis mit #DIV/0! in allen Zellen in Spalte D und E
Gruß
eddy
to top
#10
Mir entgeht der Sinn dieser Aktion.
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Diagrammformat anpassen Esteban290 1 59 07.11.2016, 17:16
Letzter Beitrag: shift-del
  Kopfzeile per Makro mit Textausschnitten von mehreren Zeilen anpassen Marco112 2 306 29.08.2016, 12:10
Letzter Beitrag: Marco112
  Listbox-Höhe soll sich automatisch an Anzahl der Einträge anpassen Lupy 7 443 27.08.2016, 21:05
Letzter Beitrag: Käpt'n Blaubär
  Nachkommastellen situativ anpassen und bei Bedarf mit Nullen auffüllen Vince440 8 532 02.08.2016, 21:26
Letzter Beitrag: schauan
  x-Achse in Diagramm anpassen lycaner 13 963 28.07.2016, 19:19
Letzter Beitrag: schauan
  Code anpassen! cysu11 26 1.761 27.06.2016, 16:50
Letzter Beitrag: schauan
  Schriftfarbe automatisch an Wert anpassen joshua 1 397 28.04.2016, 07:40
Letzter Beitrag: RPP63
  vorhandenes Makro anpassen, Abfragebereich ändern Dietmar65 5 536 24.04.2016, 19:25
Letzter Beitrag: Steffl
  Rangfolge anpassen nach Kategorie (Office 2010) dicken 10 843 19.04.2016, 14:42
Letzter Beitrag: BoskoBiati
  Code anpassen 32/64 Bit herbert0803 6 847 28.03.2016, 10:04
Letzter Beitrag: herbert0803

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste