Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Datum abgleichen und ggf. Wert aus Zelle wiedergeben
#1
Hallo ihr lieben,

es ist schwer nach was zu suchen, wenn einem die richtigen Worte fehlen.
Deshalb versuche ich wie immer mein Problem zu schildern.

In einem Arbeitsblatt ( Name: Eingabe Termine )
Sollen in B die Termine stehen z.B. Tag der offenen Tür , Führung mit FCB etc.
In C steht dann das dazugehörige Datum z.b. 01.01.2020
In D soll hierfür eine Abkürzung eingetragen werden z.B. F/FCB ( Führung mit FCB ) 

Nun bekommt das ganze Exce-file noch 12 weitere Arbeitsblätter, für jeden Monat eins. 
Hier steht in    D4 der 1.1, E4 der 2.1. ....

Nun soll Ecxel im Blatt Eingabe Termine schauen ob für den 1.1. ein Termin in der Liste steht und mir in D5 die Abkürzung des Termins erzeugen.

Wie realisiere ich das ganze?
Natürlich ist die Eingabe der Terminliste nicht sortiert, da sich manche Termine schon relativ früh eintragen lassen und andere jedoch
sehr spät dazu kommen.

Mein Gedankenansatz war zunächst, über KKLEINSTE die Daten (Datum) zu sortieren =KKLEINSTE(Bereich;1), =KKLEINSTE(Bereich;2) usw.
Nun weiß ich jedoch nicht wie ich die Abkürzungszelle automatisch dazu erzeugen kann.

Ich danke euch schon einmal für eure Antworten.

LG Tobi
Antwortento top
#2
Hola,



Zitat:Nun bekommt das ganze Exce-file noch 12 weitere Arbeitsblätter, für jeden Monat eins.


warum? Gleichartige Daten gehören auf ein Blatt und sind somit recht simpel auszuwerten.

Gruß,
steve1da
Antwortento top
#3
Hallo,

z.B. so:

Arbeitsblatt mit dem Namen 'Tabelle2'
 BCDEFGH
104.06.2017L11.1.2.1.3.1.4.1.5.1.
223.01.2022W2T75 S78S22G296
325.06.2021Q3R368  N172 
414.03.2018M4   B227 
510.08.2021B5   E255 
610.01.2022M6   U274 
726.01.2017J7     
806.02.2024E8     
911.10.2021J9     
1008.12.2016E10     
1119.07.2023U11     
1204.10.2019N12     
1322.01.2019V13     
1431.12.2021L14     
1503.09.2018W15     
1606.11.2021M16     
1703.04.2017U17     
1804.04.2016F18     

ZelleFormel
D2=WENNFEHLER(INDEX($C:$C;AGGREGAT(15;6;ZEILE($B:$B)/(TAG($B:$B)=WECHSELN(LINKS(D$1;2);".";"")*1)/(MONAT($B:$B)=WECHSELN(RECHTS(D$1;3);".";"")*1);ZEILE(A1)));"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg


@Steve,

die Daten sind wohl schon auf einem Blatt, sollen aber jetzt tageweise, unabhängig vom Jahr, ausgewertet werden.
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#4
Nun ja, so einfach ist es leider nicht.
Um sich ein genaues Bild davon zu machen habe ich das File mal angehängt.
Es geht um einen "Masterplan" für ein Theater. 

Nun soll im Arbeitsblatt Januar beim 2.1. und somit in E7 GP3 auftauchen.
Damit man den "Kalender" aber in der Hosentasche tragen kann ( also auf Papier ) sollte
das ganze kompakt sein. 

Da ich in den einzelnen Arbeitsblätter so wenig wie möglich jährlich verändern will,
sollten die Termine über eine Maske eingetragen werden können.

Danke für die Mühen

LG Tobi


Angehängte Dateien
.xlsm   Masterplan.xlsm (Größe: 15,99 KB / Downloads: 4)
Antwortento top
#5
Hallo,

das hat mit Deiner Ausgangsfrage ja absolut nichts mehr zu tun.
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#6
Hmm nicht?

Nun ja, worum es mir geht sieht man jetzt in dem File.
Danke schon einmal für eure Antworten,
wenn Ihr mir dann die passende Formel noch erklären könntet wäre ich sehr dankbar.

LG Tobi
Antwortento top
#7
(17.01.2017, 11:39)Tobias159 schrieb: Nun soll im Arbeitsblatt Januar beim 2.1. und somit in E7 GP3 auftauchen.
Das ist ein einfacher SVERWEIS().
Code:
=INDEX('Eingabe Termine'!$D$5:$D$44;VERGLEICH(E3;'Eingabe Termine'!$C$5:$C$44;0))
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
[-] Folgende(r) 1 Benutzer sagt Danke an shift-del für diesen Beitrag:
  • Tobias159
Antwortento top
#8
Herzlichen Dank Shift-shel, soweit habe ich die Formel eingefügt und es funktioniert!

Wenn ich jetzt die Funktion verstanden habe, heißt es soviel wie:
Wenn Datum1 mit Datum2 übereinstimmt, dann schreibe mir den Wert x aus dem definierten Bereich.

So nun geht das ganze Spiel weiter,
Jetzt soll die Funktion jedoch zwei Attribute vergleichen.
Das Datum und eine bestimmte Abkürzung aus dem Bereich.
Wenn jene zwei Attribute übereinstimmen soll er mir einen passenden Wert liefern.

Danke schon einmal im voraus.
Antwortento top
#9
(18.01.2017, 11:26)Tobias159 schrieb: So nun geht das ganze Spiel weiter,
Mal sehen ob sich noch ein Mitspieler findet.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#10
Ok, es scheint keiner mehr mitspielen zu wollen, schade.

Vielleicht gibt es für dieses Problem einen workaround. 
Der könnte für mich wie folgt aussehen:

Suche in Spalte X alle Ereignisse mit dem Wert "TT" und führe sie nach dem
kleinsten Datum in Spalte AA auf.

=WENN($K$5:$K$162=$P$2;KKLEINSTE($I$5:$I$162;Termine!O2);"")

P2= der Wert hier TT
Termine!O2 = 1   O3=2 .... ( zum runterziehen ) :)
Leider bekomme ich trotzdem nur 1 Wert 
Das zweite "TT" scheint er nicht zu finden.   

Das ganze müsste ich dann für alle angegebenen Werte machen, ist zwar eine große Schreibarbeit aber egal.
Danach könnte ich für die passenden Zeilen im Kalender die INDEX Funktion wie oben bereits erstellt übernehmen.

Wie könnte nun die passende Formel aussehen?

Danke
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste