Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Werte automatisch verteilen
#1
Hallo Zusammen

Ich habe einen Ausgangswert (A1) mit 33 und einen Endwert (A7) 233
Nun möchte ich in den Zellen A2 bis A6 automatisch gleichzeitig verteilen mit ganzen Zahlen.

Hinweis: Automatisch. Will heissen die Anzahl Verteilzellen (im Beispiel A2 bis A6 = 5) sind variabel, weshalb eine einfache Formel $a$1 + (A7-A1/5) nicht in Frage kommt.

Besten Dank für Eure Unterstützung.
Antwortento top
#2
Dafür gibt es die Formel =ZUFALLSBEREICH().
In A2

Code:
=ZUFALLSBEREICH(0;$A$7-$A$1)
In A3

Code:
=ZUFALLSBEREICH(0;$A$7-$A$1-SUMME($A$2:A2))
Die Formel in A3 runterziehen bis A6
Schöne Grüße
Berni
Antwortento top
#3
Herzlichen Dank! Muss ich in Ruhe näher anschauen.
Antwortento top
#4
Hallo p...,

ich habs so verstanden (fürA2):  =RUNDEN(A1+(Ziel-A1)/(ZEILE(Ziel)-ZEILE(A1));0)


ps
Das wäre aber ein Zufall, wenn der Zufall gleichmäßig wäre. Sorry, hatte gleichverteit statt "gleichzeitig verteilt" gelesen.
helmut

Für mich ist die Möglichkeit in Excel an Zellen und Bereichen Namen zu vergeben die wichtigste Funktionalität.
Sie macht Formeln und den VBA-code verständlicher. Für Makros gilt die Regel: "Nur über benannte Bereiche auf den Inhalt der Zellen zugreifen."
Und wofür sind Regeln da? Um nachzudenken bevor man sie bricht.





Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste