Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Pivot Tabellen zählenwenn
#1
Moin Moin.

Ich habe eine Frage.
Momentan erstelle ich auf der Arbeit eine Excel Tabelle für Fonds. Da es Arbeit ist darf ich es nicht hochladen.

In Tabelle1 habe ich 5 Dropdownlisten mit den Namen der Fonds erstellt.
Schön und gut, er liest die Namen aus Tabelle2 ohne Probleme.

Nun soll er zählen wenn ein Anleger diesen Fond hat.
Hierzu habe ich =zählenwenn(Tabelle2!b2:ak1337;Tabelle2!b1=b2) verwendet.

Tabelle2!B2:AK1337 ist der Bereich der Pivottabelle wo steht wie viele Antzeile der jeweilige Anleger (Zeile A) vom Fond (Spalte A) besitzt.

Irgendwie will er aber nicht.....

Hilfe?
Antwortento top
#2
Hallo,

Zitat:Da es Arbeit ist darf ich es nicht hochladen.

kein Mensch verlangt deine Originaldatei. Lade eine auf etwa 10 Datensätze abgespeckte und anonymisierte Beispieldatei hoch. Wichtig ist, dass der Aufbau der Beispieltabelle deinem Original entspricht.
https://www.clever-excel-forum.de/thread-326.html
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#3
Sorry,da habe ich gar nicht dran gedacht.


Angehängte Dateien
.xlsx   FondAnonym.xlsx (Größe: 1,39 MB / Downloads: 7)
Antwortento top
#4
Hola,


Code:
=SUMMENPRODUKT(('Fond Anteile'!$A$3:$A$39=C2)*('Fond Anteile'!$B$3:$ARJ$39))

Gruß,
steve1da
Antwortento top
#5
Vielen vielen Dank!

Nun habe ich nur noch eine frage.

In dem Anteil Blatt habe ich ja unter anderem Fond 1 & 2 stehen.

Er soll mir ausgeben wie viele Anleger sowohl Fond 1 als auch 2 besitzen.

Bei Zählenwenns wäre es mir klar. SummenProduktWenns gibt es ja aber leider nicht.
Antwortento top
#6
Hola,


Code:
=SUMMENPRODUKT((('Fond Anteile'!$A$3:$A$39=C2)+('Fond Anteile'!$A$3:$A$39=C3))*('Fond Anteile'!$B$3:$ARJ$39))

Gruß,
steve1da
Antwortento top
#7
Vielen Dank für die schnelle Antwort.

Mich wundert nur eins.

Fond 4 ist 2 mal vertreten.

Gebe ich aber an Fond 1 & 4 bekomme ich 4 heraus.

Zählt er die irgendwie doppelt?
Antwortento top
#8
Hola,

was hat denn Fond 4 mit Fond 1+2 zu tun?
Es werden die 1er summiert, wenn in Spalte A Fond 1 oder Fond 2 steht. Ich erhalte da 12 als Summe.

Gruß,
steve1da
Antwortento top
#9
Jeder Anleger kann ja nicht nur bei einem Fond anlegen.

In Spalte A stehen ja die Fond Namen, bei mir zB Fond 1 oder Fond 3.
In Zeile 2 stehen die Kunden, wie K1 und K100.

In der Pivot sieht man in welche Fonds der Anleger investiert hat.
Es sind ja ungefähr 13000 Kunden, wenn ich mich recht entsinne.

Nun möchte ich wissen wie viele Kunden in Fond 1 und 2 oder einem anderen gleichzeitig investiert haben.
Um auszuwerten, welche Fons Kombis beliebt sind.

Da kann es ja nicht sein, das 2 Anleger in Fond 4 investiert haben und wenn man fragt wer in Fond 1 und 4 gleichzeitig investiert hat 4 rauskommt.
Antwortento top
#10
Hola,

ich kann das nur anhand deiner Beispieldatei sagen.
Code:
=SUMMENPRODUKT(('Fond Anteile'!$A$3:$A$39=C2)*('Fond Anteile'!$B$3:$ARJ$39))
Zieh die Formel nach unten und du erhälst die Anzahl der Kunden, die in den jeweiligen Fond investiert haben.

Bei mir erscheinen dann die Zahlen 4, 8, 9, 0, 186 für die Fonds 1-5. Also ergibt Fond1+2 12.

Was erwartest du denn konkret für Zahlen?

Gruß,
steve1da
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste