Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Berechnung Arbeitzeit
#1
Hi Leutz,

ich habe ein Problem was ich nicht lösen kann....

ich habe eine Formel die mir ausrechnet wenn das Datum ein Sonntag ist wie hoch der Zuschlag ist für Sonntagsarbeit(25%)

=WENN(WOCHENTAG(B18;2)>6;H18*0,25;"0")

B18=Datum
H18=Betrag

H18 ist nur die Summe der geleisteten Stunden x Stundensatz


Diese funktioniert super, nur hatte ich ein Denkfehler: Wenn es aber ein Samstag ist kann es passieren das auch nach 24:00 Uhr gearbeitet wird. da greift die Formel natürlich nicht Sad

Meine restlichen Felder bestehen aus:

C18= Beginn der Arbeitszeit
D18= Ende der Arbeitszeit
E18= Pause
F18= geleistet Arbeitszeit

Habt ihr ne Idee wie ich das lösen kann?

Danke vorab

Staff
Antwortento top
#2
Hallo,

zuerst einmal solltest du die Anführungszeichen um die 0 entfernen. Dann ware es super, wenn du deine (anonymiserte) Datei hochladen würdest, statt nur zu beschreiben, wie diese aussieht.

Außerdem wie sieht das aus, wenn du am Sonntag anfängst, aber erst am Montag aufhörst? Kriegst du für die Zeit nach Mitternacht trotzdem den Zuschlag?
Viele Grüße,
Matthias

-------------------------------------------------------------------------------------------

Man muß nicht alles wissen, man muß nur wissen, wie man die Lösung findet.
Antwortento top
#3
Hi Danke für deine Hilfe,

Datei ist beigefügt. Zuschlag soll es nur von Sonntag 00:00-24:00 Uhr geben

staff


Angehängte Dateien Thumbnail(s)
       
Antwortento top
#4
Hallo,

was du da angefügt hast, sind Bilder, keine Datei.
Viele Grüße
Klaus-Dieter
Antwortento top
#5
Verdammt habe nur Datei gelesen Wink


Angehängte Dateien
.xlsx   Test.xlsx (Größe: 18,34 KB / Downloads: 4)
Antwortento top
#6
Im Anhang mein Lösungsvorschlag - bzw. ohne Hilfsspalten:
Code:
=(WENN(WOCHENTAG(B13+WENN(D13<C13;1;0);1)=1;D13;WENN(WOCHENTAG(B13+WENN(D13<C13;1;0);1)=2;1;0))-WENN(WOCHENTAG(B13;1)=1;C13;0))*0,25*24*$L$5


Angehängte Dateien
.xlsx   Test.xlsx (Größe: 19,41 KB / Downloads: 6)
Viele Grüße,
Matthias

-------------------------------------------------------------------------------------------

Man muß nicht alles wissen, man muß nur wissen, wie man die Lösung findet.
[-] Folgende(r) 1 Benutzer sagt Danke an Matthias84 für diesen Beitrag:
  • staff007
Antwortento top
#7
boah das sieht schonmal richtig gut aus.
Ich teste das mal.

vielen vielen Dank

staff
Antwortento top
#8
Hi,

ich weiß nicht, wie Du auf 41,80 am 1.10. kommst, aber ich würde das so machen:

Arbeitsblatt mit dem Namen 'Tabelle1'
K
11Sonntags-  zuschlag 25%
12-   €
13-   €
14-   €
15-   €
16-   €
1717,10 €
1822,80 €
19-   €
20-   €
21-   €

ZelleFormel
K12=((REST(B12;7)=0)*(D12<C12)*D12+(REST(B12;7)=1)*(MAX((D12<C12);D12)-C12))*24*$L$5*0,25
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.01] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Stellt sich die Frage, wo die Pausen eingerechnet werden.

Noch etwas verkürzt:


Code:
=((REST(B12;7)=0)*(D12<C12)*D12+(REST(B12;7)=1)*(MAX((D12<C12);D12)-C12))*6*$L$5

mit WENN:


Code:
=WENN((REST(B12;7)=0)*(D12<C12);D12;WENN(REST(B12;7)=1;WENN(D12<C12;1;D12)-C12))*$L$5*6
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#9

.xlsx   180921 Lohnzuschlag-an Sonn-und-Feiertagen-25Proz.xlsx (Größe: 30,85 KB / Downloads: 6)

Die Pausen sind hier gesetzlich eingestellt von 6:-6:30/9:-9:15. Können zentral korrigiert werden. Können individuell überschrieben werden.
Antwortento top
#10
Hi Leutz,

danke erstmal für Eure Unterstützung ist echt klasse.

die letzten 2 Sachen habe ich noch nicht getestet, mache ich aber noch Smile
wenn ich hier noch aufrunden will am Beispiel von Matthias84 wie setze ich das um?

Code:
=(WENN(WOCHENTAG(B13+WENN(D13<C13;1;0);1)=1;D13;WENN(WOCHENTAG(B13+WENN(D13<C13;1;0);1)=2;1;0))-WENN(WOCHENTAG(B13;1)=1;C13;0))*0,25*24*$L$5

Habe das mal beim Nachtzuschlag gemacht, bekomme das aber bei der anderen Formel nicht hin Sad

Code:
=AUFRUNDEN($L$6*10%;2)*I13*24
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste