Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Summe
#1
Hey Leute,

ich habe folgende Datenreihe die aufsteigend ist:

10
12
15
18
25
40
60
60
60
60
61
62
64
67


Ich möchte nun in der nächsten Spalte immer ein X stehen haben, wenn ich (zum letzten X) eine Erhöhung von mindestens 5 habe.

Das müsste dann so aussehen:

10   X
12
15   X
18
25   X
40   X
60   X
60
60
60
61
62
64
67   X


Wie bekomme ich das hin? Ich stehe gerade auf dem Schlauch.

Vielen Dank schonmalSmile
Antwortento top
#2
Hi, 
Ungetestet :
=wenn(a2-index(a:a;Verweis(9;1/(b$2:b2="x");zeile(b$2:b2))=5;"x";"")
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#3
Hallo, der arme Schlauch... Hat deine Tabelle Übeschriften..? Steht in der ersten Zelle (nach einer möglichen Überschrift) in der zweiten Spalte immer ein "x" - als Anfang oder muss die größer gleich fünf sein..?
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2019
Antwortento top
#4
Wink 
Auf die schnelleSmile
Die 10 steht in A1, Formel B1
=WENN(A1>=5;"X";"")

Formel B2 zum runter kopieren . (Matrix-Formel Eingabe mir STRG+SHIFT+RETURN abschließen)
=WENN(A2-(MAX(($A$1:A1)*($B$1:B1="x")))>=5;"x";"")

LG Holger
[-] Folgende(r) 1 Benutzer sagt Danke an echo für diesen Beitrag:
  • StrammerMax
Antwortento top
#5
Hallo Holger, cool. Ohne Formel mit CSE-Abschluss wäre das noch cooler... mit MAX() und INDEX() z. B.
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2019
Antwortento top
#6
Hi,

korrigierte Formel:


Code:
=WENN(A2-INDEX(A:A;VERWEIS(9;1/(B$1:B1="x");ZEILE(B$1:B1)))>=5;"x";"")
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#7
(04.09.2018, 10:00)BoskoBiati schrieb: Hi,

korrigierte Formel:


Code:
=WENN(A2-INDEX(A:A;VERWEIS(9;1/(B$1:B1="x");ZEILE(B$1:B1)))>=5;"x";"")

Das scheint so leider nicht zu funktionieren (bei mir).
Antwortento top
#8
Perfekt.
Das funktioniert einwandfrei - vielen DankSmile

Das mit der Eingabe sehe ich aber auch das erste Mal.
Antwortento top
#9
(04.09.2018, 11:59)StrammerMax schrieb: ...

Das mit der Eingabe sehe ich aber auch das erste Mal.

Hallo, da gibt's Alternativen. Man muss nicht so... Die Arbeit im Umgang mit CSE-Formeln ist gewöhnungsbedürftig... Zudem können sie Ressourcenfresser sein... Wie geschrieben: es gibt auch andere Möglichkeiten...
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2019
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • StrammerMax
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste