Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

List mit Vornamen
#1
Hallo,

ich habe einen weg gefunden, um Vornamen aus einer Liste zu extrahieren:

A1: "Aadu ♂" oder "Aagje ♀" oder "Aale ♂♀" 
C2: =WENN(ODER(A1="Mail";A1="Service";A1="Report");A1;LINKS(A1;LÄNGE(A1)-2))

Das kürzt die Spalte um die letzten zwei Zeichen.

Wie man oben sieht sind in den Tabelle aber 2 oder 3 Zeichen im Nachgang zum Namen. Es bleibt also beim Namen "Aale" ein Leezeichen dran. Alle weiteren SVERWEIS-Formen funktionieren, nur beim Leezeichen geht es halt nicht...

Weis jemand darauf eine Antwort?

Habe es schon mir GLÄTTEN, WECHSELN oder ERSETZEN probiert, es ging nicht (Die Namen enthalten ein ' voran)

Tabellenauszug anbei.

Vielen Dank!

Grüße

Derk


Angehängte Dateien
.xlsx   Namen.xlsx (Größe: 11,84 KB / Downloads: 5)
Antwortento top
#2
Hi,

so z.B.:

Tabelle1

ABC
1Name 2m/w/nVorname
2Aadolf ?HerrAadolf
3MailLieber(r)Mail
4ServiceLieber(r)Service
5ReportLieber(r)Report
6Aadu ?HerrAadu
7Aage ?HerrAage
8Aagje ?FrauAagje
9Aale ??Lieber(r)Aale
Formeln der Tabelle
ZelleFormel
C2=LINKS(A2;SUCHEN(ZEICHEN(160);A2&ZEICHEN(160))-1)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • Derk
Antwortento top
#3
Danke, klappt!
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste