Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

ABC Analyse
#1
Question 
Hallo. Ich möchte eine ABC Analyce für mehrer Artikel machen, was kein Problem ist. Nun will ich aber eine neue Tabelle hinzufügen wo untereinander A,B und C stehen und daneben sollen jeweils aus der Haupttabelle die Artikelnummern von A,B und C stehen. Also nicht zählen wieviele Artikel es sind, sondern den Inhalt von mehreren Zellen in eine Zelle bringen.
Ist das möglich?
Gruß
Steven19
Antwortento top
#2
Hi

Zitat:Also nicht zählen wieviele Artikel es sind, sondern den Inhalt von mehreren Zellen in eine Zelle bringen.

So generell ohne weitere Angaben zu kennen würde ich an SVERWEIS, INDEX/VERGLEICH usw. denken. Um dir aber gezielt helfen zu können, solltest du uns (d)eine (Muster)Tabelle zur Verfügung stellen.

So kannst du Arbeitsmappen hochladen, und hier wird dir gezeigt, wie du Tabellenausschnitte einstellst.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#3
OK.
Hier nochmal vereinfacht. Die Artikel aus Tabelle 1 sollen in die Tabelle 2 bei Artikel eingefügt werden


Angehängte Dateien
.xlsx   ABC_Sortierung.xlsx (Größe: 9,3 KB / Downloads: 5)
Gruß
Steven19
Antwortento top
#4
Hallo,

solche Verkettungen gehen nur über Hilfszellen oder VBA.

Was ziehst Du vor?
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#5
Hi,
würde mir beides gerne mal anschauen. Wobei ich keine Erfahrungen mit VBA habe.
Gruß
Steven19
Antwortento top
#6
Hallo,

hier mal eine Formel-Lösung, den Bereich H:S musst Du auf Deine Gegebenheiten anpassen, der kann durchaus breiter sein, je nach Anzahl der Eintragungen.

Arbeitsblatt mit dem Namen 'Tabelle1'
 BCDEFGHIJK
1Tabelle 1  Tabelle 2  Ohne Matrixformel: Hilfsspalte in D 
2Artikel-Nr,ABC ABCArtikel     
3IA6501AI,VI,VIII I,I,VI,I,VI,VIII, 
4IIB6601BII,III II,II,III,  
5IIIB6602CIV,V,VII IV,IV,V,IV,V,VII, 
6IVC6701       
7VC6702   Mit Matrixformel:   
8VIA6502   I,I,VI,I,VI,VIII, 
9VIIC6703   II,II,III,  
10VIIIA6503   IV,IV,V,IV,V,VII, 
11….        

ZelleFormel
F3=LINKS(VERWEIS(9;1/(H3:S3<>"");H3:S3);LÄNGE(VERWEIS(9;1/(H3:S3<>"");H3:S3))-1)
H3=WENN(ZÄHLENWENNS($D:$D;"<"&(CODE($E3)+1)*100;$D:$D;">"&CODE($E3)*100)<SPALTE(A1);"";G3&INDEX($B:$B;VERGLEICH(KKLEINSTE($D:$D;SPALTE(A1)+SPALTEN($H$3:$S$3)*ZEILE(A1)-ZÄHLENWENN($H$2:$S2;""));$D:$D;0))&",")
H8{=WENN(ZÄHLENWENN($C:$C;$E3)<SPALTE(A1);"";G8&INDEX($B:$B;KKLEINSTE(WENN($C:$C=$E3;ZEILE($C:$C));SPALTE(A1)))&",")}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg


Mit VBA käme die Bildung von Arrays in Frage, da bin ich aber nicht so fit.
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste