Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

wenn #NV auftritt komplette Reihe ausblenden
#1
Guten Tag zusammen,

ich komme mal wieder nicht weiter.

Ich habe ein Tabellenblatt, mit einer Spalte, die abhängig von Dropdown Menüs, die sich auf einem anderen Tabellenblatt befindet.
Das heißt also, dass ich manchmal Ergebnisse angezeigt bekomme und manchmal kommt halt der Fehler #NV.

Wenn der besagte Fehler auftritt, würde ich gerne die komplette Zeile, in der sich das #NV befindet ausblenden.

Die besagte Spalte ist D, die Fehler treten nur in D11,D12,D17,D18,D22 und D23 auf.

Mein bisheriger Code
Code:
Cells(11, 4).AutoFilter Field:=4, Criteria1:="<>#N/A"

Und diesen Code mit Private Sub Worksheet_Calculate()

Viele Grüße
ExcelVBAAnfänger
Antwortento top
#2
Hallo,

lade doch bitte deine (anonymisierte) Datei hoch. Dann wird es einfacher einen Lösungsvorschlag zu erstellen.
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top
#3
Hallo Klaus-Dieter,

erst mal Danke für die schnelle Antwort.
Das mit der Beispiel Datei wird schwierig, weil diese von einem Unternehmen ist und dann eine auch nur annähernd ähnliche Datei hoch zu laden wird sehr schwer.

Würden Sie also auf den ersten Blick sagen, dass mit dem Code an für sich, nichts falsch ist?

Gruß
ExcelVBAAnfänger
Antwortento top
#4
Hallo,

man könnte zum Beispiel versuchen die #NV anzeige durch Änderung der Formel zu unterdrücken, dazu müsste man aber die Formel kennen.
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top
#5
Hallo Klaus-Dieter,

=SVERWEIS(C11;Daten!A$5:$Q$94;2;0)

so sieht der Code in den entsprechenden Zellen aus. (Der ist jetzt in D11 drin)

Gruß
ExcelVBAAnfänger
Antwortento top
#6
Hallo,

dann schreibst du das so: =WENNFEHLER(SVERWEIS(C11;Daten!A$5:$Q$94;2;0);"") dann erscheint anstelle des #NV eine leere Zelle. Die kannst du dann so:

Code:
Cells(11, 4).AutoFilter Field:=4, Criteria1:="<>"
  
ausfiltern.
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top
#7
Hallo Klaus-Dieter,

wäre dann nicht das Resultat, dass dann die jeweilige Zelle einfach leer ist?
Weil das hatte ich schon und es war leider nicht ausreichend.
Mein Vorgesetzter will, dass die Reihe in dem Fall dann ausgeblendet wird.

Gruß
ExcelVBAAnfänger
Antwortento top
#8
Hallo, 19

nimm noch einen "WENNFEHLER" dazu: 21

Code:
=WENNFEHLER(SVERWEIS(C11;Daten!A$5:$Q$94;2;0);"")

Falls du es über VBA machen möchtest, dann würde ich das "Worksheet_Calculate" meiden. Das wird u. U. zu oft ausgelöst.
________
Servus
Case
Antwortento top
#9
Hallooo,

ich hatte doch geschrieben, dass sich das mit einer entsprechenden Anweisung ausblenden lässt. Wenn es in der Spalte auch sonst leere Zellen geben kann, musst du mit der Formel halt etwas anderes in die Zelle eintragen lassen, das man dann ausfiltern kann. Ich wusste schon, warum ich nach der Datei gefragt habe.
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top
#10
Hallo,

ich bin gerade noch auf der Arbeit und kann hier keine Dateien hochladen.
Werde mich dann später zu Hause hinsetzen und eine Beispiel Datei hoch laden.

Gruß
ExcelVBAAnfänger
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste