Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

verschiedene Werte einer Spalte auszählen
#1
Hallo Wissende,

ich habe eine Spalte in der viele verschiedene Werte stehen. Alle in der Form: 3,5  4,2  3,9  5,2  3,7  usw.

Jetzt möchte ich zählen, wie viele Werte zwischen 1,0 und 1,9 liegen. Wie viele zwischen 2,0 und 2,9 liegen usw.

Gibt es da ne Formel ohne VBA?

Danke für eure Hilfe

Beispiel ist beigefügt. Blau soll als Ergebnis erscheinen.


Angehängte Dateien
.xls   Beispiel.xls (Größe: 16,5 KB / Downloads: 0)
Antwortento top
#2
Das steht alles in A1 drin?
Und wenn ja, sicher auch mal mehr oder weniger Daten denke ich mal?

Dann wird es nach meiner Ansicht recht schwer, so etwas mit einer Formel zu realisieren.
UND WENN, IST ES SICHER SCHWIERIGER ALS MIT EINEM MAKRO!

Aber da gibt es wissendere als mich Blush

PS: Eine Beispieldatei würde auch hier sehr helfen!
Antwortento top
#3
Hi,

wenn, wie von Basisa angenommen, alles in einer Zelle steht, dann würde ich diesen Text erst einmal trennen. Das geht am schnellsten über Daten/Text in Spalten; als Trenner nimmst du das Leerzeichen.

Danach schreibst irgendwohin eine 1, kopierst sie mit Strg & + und markierst den kompletten getrennten Bereich. Mit Rechtsklick öffnest du "Inhalte einfügen" und aktivierst "multiplizieren". Jetzt hast du echte Dezimalzahlen, die du einfach zählen kannst.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#4
Sorry, mein Fehler... nicht in einer Zelle sondern in einer Spalte.

Beispiel ist beigefügt.  Blau soll als Ergebnis erscheinen.


Angehängte Dateien
.xls   Beispiel.xls (Größe: 16,5 KB / Downloads: 7)
Antwortento top
#5
Hi,

so:

Arbeitsblatt mit dem Namen 'Tabelle1'
BCDEF
2Anzahl
1,0 - 1,9
Anzahl
2,0 - 2,9
Anzahl
3,0 - 3,9
Anzahl
4,0 - 4,9
Anzahl
5,0 - 5,9
314430
414430

ZelleFormel
B4=ZÄHLENWENNS($A$3:$A$14;">=1";$A$3:$A$14;"<=1,9")
C4=ZÄHLENWENNS($A$3:$A$14;">=2";$A$3:$A$14;"<=2,9")
D4=ZÄHLENWENNS($A$3:$A$14;">=3";$A$3:$A$14;"<=3,9")
E4=ZÄHLENWENNS($A$3:$A$14;">=4";$A$3:$A$14;"<=4,9")
F4=ZÄHLENWENNS($A$3:$A$14;">=5";$A$3:$A$14;"<=5,9")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste