Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

mehrere WENN-Funktionen in einer Formel
#1
Ich möchte mehrere WENN-Funktionen in eine Formel zusammenführen und bekomme es nicht hin.

Die Felder in Spalte I sollen folgende Bedingungen erfüllen:
- Wenn D=1, dann soll es die Tage ausrechnen =WENN(D2;TAGE(H2;G2-1);"") ->funktioniert
- Wenn D=0, dann soll es das Feld I leer bleiben (wird ja mit der obigen Formel abgedeckt) ->funktioniert
- Wenn die obigen Bedingungen erfüllt sind, jedoch das Feld in Spalte H leer ist, dann soll es die Tage von Beginn bis zum heutigen Tagesdatum -1 ausrechnen. Und hier scheitere ich glaub...

Als Einzelformel - siehe Feld I23 - funktioniert es (wenn ich ehrlichgesagt auch nicht verstehe, warum): =WENN(G23="";"";HEUTE())
Ich verstehe nicht, wieso G23="", da es ja eigentlich H23 ist, das leer sein müsste, damit es nach meiner Logik stimmt.

Beide Formeln zusammen funktionieren aber definitiv nicht. Das Ziel wäre, eine Formel zu bekommen, die alle 3 Bedingungen erfüllt. Meine Kollegin und ich zerbrechen uns seit Stunden den Kopf - kann jemand helfen?


Angehängte Dateien
.xlsx   Absenzmanagement.xlsx (Größe: 18,86 KB / Downloads: 2)
Antwortento top
#2
K2: =WENN(F2;WENN(H2;H2;HEUTE())-G2+1;"")
[-] Folgende(r) 1 Benutzer sagt Danke an LCohen für diesen Beitrag:
  • Limelight
Antwortento top
#3
wenn ich diese Formel auf Spalte I anpasse und runterziehe, bekomme ich in Felder I7, I8, I16 und I19 Wert-Fehlermeldungen

=WENN(D7;WENN(H7;H7;HEUTE())-G7+1;"")*L7

Für die Spalten J und K funktioniert sie

Ok, habe meinen Fehler gefunden.

In Spalte I muss das Ergebnis noch mit Spalte L multipliziert werden. Und 0*100% kann er natürlich nicht rechnen...
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste