Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

dynamische Kalenderwoche erstellen
#1
Hallo.

Ich habe einen recht umfangreich Berechnung von meinen Arbeitsstunden mit auswerung. Alles ist in einem komplett dynamischen Kalender integriert. Ich möchte nun auf einem gesonderten Tabellenblatt die Kalenderwoche mit Datumsspanne von bis darstellen. Allerdings sollen nur die Montage dargestellt werden. Im Grunde möchte ich in A1-A52 dynamisch die Kalenderwochen darstellen. In B1-B52 die Datumsspanne. Es soll dynamisch gehalten werden. Hat jemand eine Idee?
Antwortento top
#2
Hi,

zeig bitte eine Beispieldatei (keine Bildchen!!) mit händisch eingetragenem Wunschergebnis. https://www.clever-excel-forum.de/Thread...ng-stellen
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
Hier eine sehr stark vereinfachte Tabelle

Auf dem 2. Tabellenblatt erste Spalte möchte ich die kalenderwoche darstellen, die auf die tatsächliche verweist, die im Kalender Blatt dargestellt wird.


Angehängte Dateien
.xlsx   Mappe (4).xlsx (Größe: 10,26 KB / Downloads: 5)
Antwortento top
#4
Hi,

im Blatt Kalender legst du eine Hilfsspalte an (kannst sie bei Bedarf ausblenden):

Arbeitsblatt mit dem Namen 'kalender'
ABC
12020JahrHS
201.01.2020Di
302.01.2020Mi
403.01.2020Do
504.01.2020Fr
605.01.2020Sa
706.01.2020So2
807.01.2020Mo
908.01.2020Di
1009.01.2020Mi
1110.01.2020Do
1211.01.2020Fr
1312.01.2020Sa
1413.01.2020So3
1514.01.2020Mo
1615.01.2020Di

ZelleFormel
C2=WENN(WOCHENTAG(A2;2)=1;ISOKALENDERWOCHE(A2);"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Dann holst du die Daten:

Arbeitsblatt mit dem Namen 'KW'
ABC
1KWDatum vonDatum bis
2206.01.202013.01.2020
3313.01.202020.01.2020
4420.01.202027.01.2020
5527.01.202003.02.2020

ZelleFormel
B2=INDEX(kalender!A:A;VERGLEICH(A2;kalender!$C$1:$C$32;0))
C2=B2+7
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#5
Klasse. Genau so hab ich mir das vorgestellt. Ein fettes danke.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste