Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

arbeitstage berechnen,wenn auch Zelle leer
#1
Moin zusammen,
wie lautet die Formel,wenn in ein Zellbereich leere Zellen vorhanden sind,
in Bezug auf die Berechnung der Arbeitstage.
Gebe ich einen festen Bereich ein,dann erhalte ich keine Rauten.
Erweitere ich aber den Bereich,erhalte ich die Rauten.

Danke


Angehängte Dateien
.xlsx   test.xlsx (Größe: 9,53 KB / Downloads: 9)
Antwortento top
#2
Hi,

wenn die Zellen tatsächlich leer sind, ist das der Formel egal. Nur wenn da "Leerzellen" steht, ist die Formel beleidigt!
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#3
moin,
na leer sind sie nicht.
Die Leerzellen beinhalten SverweisFormeln.
Antwortento top
#4
Hola,

dann lass dir per Wennfehler eine 0 an Stelle von "" ausgeben. Die kannst du ja ausblenden.

Gruß,
steve1da
Antwortento top
#5
@all
Danke.
ich hab den Sverweis an Hand der Beispieldatei erweitert
=WENN(SVERWEIS(A8;Tabelle2!$A$8:$D$23;2)=0;"";(SVERWEIS(A8;Tabelle2!$A$8:$D$23;2)))
Antwortento top
#6
Hola,


Zitat:an Hand der Beispieldatei erweitert

ich seh keine Tabelle2 in der Beispieldatei.

Gruß,
steve1da
Antwortento top
#7
sorry,irgendwie funkt. das nicht,mit der berechnungSmile)
Was ich gemacht abe,ist eigentlich nur das ausblenden der 00.01.00 in der Tabelle1
Antwortento top
#8
Hola,

nein. Wenn das Ergebnis 0 ist, ersetzt du es durch "". Das führt wieder zu deinem ersten Problem.
=wennfehler(Dein_sverweis;0)

Die 0en blendest du jetzt mit dem benutzerdefinierten Zellformat aus.
Code:
0;-0;;@


Gruß,
steve1da
Antwortento top
#9
@Steve1da
ich kapier das nicht.
im Anhang hab ich es jetzt "hoffe ich" mal dargestellt,
was,wo od. wie auch immer das Problem ist.

Danke


Angehängte Dateien
.xlsx   test2.xlsx (Größe: 11,53 KB / Downloads: 2)
Antwortento top
#10
Hola,

durch das "" in deiner Formel erzeugst du wieder TEXT der in deiner Formel zu #WERT führt.
Einfach das machen was ich geschrieben habe.

Code:
=WENNFEHLER(SVERWEIS(A21;Tabelle2!$A$8:$D$23;2);0)

Dann das Zellformat dieser 3 Zellen (oder meinetwegen aller) auf

Code:
0;-0;;@
stellen.

Gruß,
steve1da
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste