Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Zugehörigkeit in einer Matrix
#1
Moin Leute, 

bin neu im Forum und hab direkt mal eine Frage.

Ich habe einen Datensatz von 5 Spalten und etwa 1.000 Zeilen. Die einzelnen Zellen sind mit Werten zwischen 1 und 99 befüllt. 
Jetzt muss ich Wertepaare ausfindig machen und diese zählen (z.B. wie häufig kommt es vor dass die Werte 44 und 88 in der selben Zeile zu finden sind).

Zuerst dachte ich da an sowas wie {=SUMME(WENN(UND($C$2:$F$1000=44;$C$2:$F$1000=88);1;0))}
Jedoch funktioniert es nur solange, wie ich nur eine Bedingung habe, also er soll zählen wie häufig die 44 vorkommt. Sobald ich die zweite hinzufüge gibt er mir 0 aus... (Obwohl es mehrere Zeilen gibt, in der die Werte gemeinsam auftauchen...)

Was noch zu sagen ist: Der Wert 44 und der Wert 88 stehen nicht immer in der selben spalte, da die Zahlen in der Arryar Kronologisch geordnet sind und wenn eine Zeile drei kleinere Werte als 44 hat und dann erst die 44 und 88 kommen, stehen diese in den Spalten 4 und 5, ist aber 44 der kleinste Wert so steht die 44 in der Spalt 1... 

Noch ein kleiner Zusatz, ich muss das Ganze anschließend noch um einen Wert erweitern, also wie oft kommt es vor dass der Wert 44, 88 und 89 zusammen in einer Zeile auftauchen... 

Ich würde mich hier über eine Hilfestellung freuen. 
Besten Dank im voraus
Manu
Antwortento top
#2
Hallo Manu,

für die Helfer wird's klarer, wenn du eine Beispieldatei (.xlsx - keine Bildchen!!) hochlädtst. Trage bitte händisch dein Wunschergebnis ein. https://www.clever-excel-forum.de/Thread...ng-stellen
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
Hallöchen,

hier wäre mal ein Beispiel - das Prinzip mit einem Hilfsspaltenansatz mit viel gezähle. Allerdings wird die blau markierte Zelle doppelt gezählt Sad

Arbeitsblatt mit dem Namen 'Tabelle2'
ABCDEF
11231#2#37
22342#3#4
33453#4#5
44564#5#6
55675#6#7
64754#7#5
73543#5#4
85345#3#4
94544#5#4
102322#3#2

ZelleFormel
E1=A1&"#"&B1&"#"&C1
F1=ZÄHLENWENNS(E1:E10;"4#5#*")+ZÄHLENWENNS(E1:E10;"5#4#*")+ZÄHLENWENNS(E1:E10;"4#*#5")+ZÄHLENWENNS(E1:E10;"5#*#4")+ZÄHLENWENNS(E1:E10;"*#5#4")+ZÄHLENWENNS(E1:E10;"*#4#5")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#4
Anhand des Beispiels von schauan (ungetestet):

=SUMME(ZÄHLENWENN(E1:E10;{"4#5#*"."5#4#*"."4#*#5"."5#*#4"."*#5#4"."*#4#5"}))

oder statt {} die "Werte" gleich in einen Bereich schreiben und dann

=SUMME(ZÄHLENWENN(E1:E10;X$1:X$6))
[-] Folgende(r) 1 Benutzer sagt Danke an LCohen für diesen Beitrag:
  • schauan
Antwortento top
#5
Vielleicht zu einfach, aber hoffentlich verständlich:
(diese Datei wird ohne jede Gewährleistung zur Verfügung gestellt, aber ich verwende einen aktuellen Virenscanner)


Angehängte Dateien
.xlsx   Zugehörigkeit_in_einer_Matrix.xlsx (Größe: 93,71 KB / Downloads: 6)
Antwortento top
#6
(14.07.2020, 15:15)WillWissen schrieb: Hallo Manu,

für die Helfer wird's klarer, wenn du eine Beispieldatei (.xlsx - keine Bildchen!!) hochlädtst. Trage bitte händisch dein Wunschergebnis ein. https://www.clever-excel-forum.de/Thread...ng-stellen

Danke für deinen Hinweis

Hier wie gewünscht einmal ein Beispiel mit einem Auszug aus den Werten und dem Wunschergebnis

   
Antwortento top
#7
... und wieder jemand, dem das Lesen unsagbar schwerfällt. Sad Ich zitiere mich mal selbst:
Zitat:eine Beispieldatei (.xlsx - keine Bildchen!!)
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#8
Ich bin ganz bei Dir, WillWissen, aber da die Aufgabe interessant ist 
(G6 muss genauso unterteilt werden mit [leer]&[leer], wie im Bildchen, und die Daten dürfen nur 1 bis 99 enthalten):

H6:

=SUMMENPRODUKT(--((LÄNGE(G5)-LÄNGE(WECHSELN(G5;" & ";)))/3+1=(15-LÄNGE(WECHSELN(WECHSELN(WECHSELN(WECHSELN(WECHSELN(
"#"&TEXT(A$1:A$999;"00")&"#"&TEXT(B$1:B$999;"00")&"#"&TEXT(C$1:C$999;"00")&"#"&TEXT(D$1:D$999;"00")&"#"&TEXT(E$1:E$999;"00");
TEXT(TEIL(WECHSELN(G5&" & "&0&" & "&0&" & "&0&" & "&0;" & ";WIEDERHOLEN(" ";99));001;99);"\#00"););
TEXT(TEIL(WECHSELN(G5&" & "&0&" & "&0&" & "&0&" & "&0;" & ";WIEDERHOLEN(" ";99));100;99);"\#00"););
TEXT(TEIL(WECHSELN(G5&" & "&0&" & "&0&" & "&0&" & "&0;" & ";WIEDERHOLEN(" ";99));199;99);"\#00"););
TEXT(TEIL(WECHSELN(G5&" & "&0&" & "&0&" & "&0&" & "&0;" & ";WIEDERHOLEN(" ";99));298;99);"\#00"););
TEXT(TEIL(WECHSELN(G5&" & "&0&" & "&0&" & "&0&" & "&0;" & ";WIEDERHOLEN(" ";99));397;99);"\#00");)))/3))
Antwortento top
#9
(15.07.2020, 08:05)WillWissen schrieb: ... und wieder jemand, dem das Lesen unsagbar schwerfällt. Sad Ich zitiere mich mal selbst:

Uff, Ich muss mich dafür entschuldigen, die .xlsx sollte eigentlich, zusätzlich beigefügt sein, das hab ich vergessen...


.xlsx   Beispiel.xlsx (Größe: 10,28 KB / Downloads: 5)
Antwortento top
#10
In meiner Formel muss natürlich G5 durch G6 ersetzt werden (mit Strg-H 7x).
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste