Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Zellen aus Spalte kopieren ohne Duplikate und mit Bedingung
#1
Liebe Excel-Freunde,

für das nachstehende Problem habe ich euch eine Beispiel-Datei hochgeladen, die sinngemäß der Original Datei ist.


In Tabelle 1 gibt es eine Spalte "Bauteil", "Prozess" und mehrere Spalten für Kriterien. Diesen Kriterien sind Zahlen von 1 bis 3 zugeordnet. In den Tabellen 2 und 3 habe ich nachgebaut wie da Ergebnis aussehen soll. Ich möchte bspw. eine Auflistung aller Bauteile habe die in Tabelle 1 dem Prozess "Spanen"  (dafür ist in Tabelle 2/3 Feld B1 vorgesehen) zugeordnet sind, inklusive der jeweiligen Kriterien und Bewertungen. D.h. ich möchte jedes Bauteil genau einmal in Spalte A haben wenn es "Spanen"  (B1 aus Tabelle 2/3) als Prozess in Tabelle 1 hat. Den ersten  Eintrag in A4 bekomme ich mit folgender Formel ohne Probleme hin:

{=INDEX(Tabelle1!A2:A39;VERGLEICH($B$1;Tabelle1!B2:B39;0))} (Steht in Tabelle 2 A4 zum Testen)

Diese Formel kann ich natürlich nicht einfach nach unten ziehen. Daher habe ich mich an eine zweite Formel gewagt die ich in A5 einsetzen möchte und dann herunterziehe:

{=WENNFEHLER(INDEX(Tabelle1!A2:A39;VERGLEICH(1;(ZÄHLENWENN($A4:A$4;Tabelle1!A2:A39)=0)*(Tabelle1!A2:A39<>"");0));"")} (Steht in Tabelle 2 A8 zum Testen)

Leider listet mir diese Formel alle Bauteile auf ohne Duplikate, ohne darauf zu achten, ob diese im Prozess "Spanen" haben. 

Ich hoffe jemand von euch hat einen schlauen Tipp und kann mir bei dieser Formel helfen. 
Ansonsten wünsche ich allen ein schönes Wochenende!

Viele Grüße

Tom


Angehängte Dateien
.xlsx   test_daten.xlsx (Größe: 14,61 KB / Downloads: 7)
Antwortento top
#2
Moin Tom,

Arbeitsblatt mit dem Namen 'Tabelle2'
A
8Bauteil_5
9Bauteil_6
10Bauteil_10
11
12

ZelleFormel
A8=WENNFEHLER(INDEX(Tabelle1!A:A;AGGREGAT(15;6;ZEILE(Tabelle1!$B$1:$B$39)/(Tabelle1!$B$1:$B$39=$B$1);ZEILE(A1)));"")
A9=WENNFEHLER(INDEX(Tabelle1!A:A;AGGREGAT(15;6;ZEILE(Tabelle1!$B$1:$B$39)/(Tabelle1!$B$1:$B$39=$B$1);ZEILE(A2)));"")
A10=WENNFEHLER(INDEX(Tabelle1!A:A;AGGREGAT(15;6;ZEILE(Tabelle1!$B$1:$B$39)/(Tabelle1!$B$1:$B$39=$B$1);ZEILE(A3)));"")
A11=WENNFEHLER(INDEX(Tabelle1!A:A;AGGREGAT(15;6;ZEILE(Tabelle1!$B$1:$B$39)/(Tabelle1!$B$1:$B$39=$B$1);ZEILE(A4)));"")
A12=WENNFEHLER(INDEX(Tabelle1!A:A;AGGREGAT(15;6;ZEILE(Tabelle1!$B$1:$B$39)/(Tabelle1!$B$1:$B$39=$B$1);ZEILE(A5)));"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Nachtrag: Die Kriterien holst du dir per SVERWEIS()
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • Blytom
Antwortento top
#3
Hallo Günter,

Super vielen Dank! Macht genau was es soll, ich danke dir!

Viele Grüße 
Tom
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste