Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Zellen abhängig der Jahreszahl zählen
#1
Hallo zusammen,
Ich möchte die Daten von Wetterstationen auswerten und habe das Problem, dass mir bei der Berechnung von Jahreswerten, dass sobald ein Tageswert für einen Parameter fehlt, das gesamte Jahr als #NV ausgegeben wird. Für manche Jahre ist das auch sinnvoll, da fast die Hälfte der Werte fehlen, aber bei anderen fehlt eben nur ein oder zwei Werte.

Ich möchte nun für jede Station für jedes gesamte Jahr und jeden Parameter einzeln die Anzahl der #NV zählen lassen.
Mein Datum ist in der Spalte B mit dem Format JJJJMMDD eingetragen, die gemessenen Parameter in den darauffolgenden Spalten (bspw. in E der Niederschlag).
In Spalte T stehen die Jahreszahlen, für die die fehlenden Werte gezählt werden sollen.
Ich habe bereits rumgespielt, aber ich komme nicht auf die richtige Formel. Mein bisheriger Versuch sieht so aus:

=ZÄHLENWENNS(B:B;LINKS(B:B;4)=TEXT(T3;0);E:E;TEXT(#NV;0))

Jedoch gibt diese Formel 0 aus, wobei in dem Testjahr einige Fehlwerte vorhanden sind.


Könnt ihr mir hier weiterhelfen?

Mfg
Remus
Antwortento top
#2
Hallo Remus,

lad mal bitte eine Beispieldatei, die vom Aufbau her deinem original entsprechen muss, hoch. Dazu lies bitte hier nach: https://www.clever-excel-forum.de/Thread...ng-stellen
Gruß Günter
Jeder Fehler erscheint unglaublich dumm,
wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
Arbeitsblatt mit dem Namen 'Aachen'
ABCDEFGHIJKLMNOPQRSTUVW
1STATIONS_IDMESS_DATUMQN_3FXFMQN_4RSKRSKFSDKSHK_TAGNMVPMPMTMKUPMTXKTNKTGKeorFMRSKRSKF
23194001015#NV3,1500543,34,4997,4-3,7850,5-7-2eor19400
33194001025#NV2,25006,9412,5993,5-7,273-3,7-10,8-13,8eor1941
43194001035#NV25002,244,72,9983,4-4,367-1,2-9,6-14,4eor1942
53194001045#NV2,15005,8433,7982,8-2,3692,8-4,6-4,1eor1943
63194001055#NV0,8500630,34,7987,4-2871,3-6,2-10,4eor1944
73194001065#NV1,15006,3205,3993,6-0,7903,8-2,9-8,3eor1945
83194001075#NV1,85110286,3994,62,4884,6-2-7,5eor1946
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

In U2 soll dann die Menge der #NV für den Parameter FM im Jahr 1940 stehen.
Antwortento top
#4
Hallo, ist nicht sexy, aber so geht's..:

PHP-Code:
=SUMMENPRODUKT(ISTNV(E1:E100)*(LINKS(B1:B100;4)=TEXT(T3;"@"))) 
Bitte Bereiche anpassen! Und bitte keine ganzen Spalten beackern!!!!
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • Remus
Antwortento top
#5
Vielen Dank!!
Auch mit der nicht sexy Lösung funktionierts endlich.

Inwiefern ist es nicht gut, dass ich ganze Spalten in den Formeln rechnen lasse? Nur als Information für spätere Formeln?
Antwortento top
#6
(11.06.2019, 18:52)Remus schrieb: ...
Inwiefern ist es nicht gut, dass ich ganze Spalten in den Formeln rechnen lasse? Nur als Information für spätere Formeln?

Hallo, weil es schnell zu Ungunsten von Rechenleistung und Performance gehen kann...
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • Remus
Antwortento top
#7
Ah, macht Sinn :D

Vielen Dank für die schnelle Hilfe!
Antwortento top
#8
Hallo,
Ich habe heute versucht, die Formel auf die anderen Wetterstationen zu übertragen.
Die Bezüge habe ich angepasst und die Länge der Spalte auf 28000 Zeilen begrenzt (um alle Tage von 1940 - 2018 einzuschließen). Bei der Station in der Beispieltabelle oben und in der darauffolgenden hat es einwandfrei funktioniert. In der zweiten wurden mir nur noch 0 für alle Parameter ausgegeben, obwohl bereits in der ersten Zelle nicht vorhandene Werte standen.
Ich habe die Formel dann bei weiteren Stationen in der Mitte und am Ende ausprobiert, bei manchen klappts, bei manchen nicht.
Ich kann nur vermuten, dass es mit den unterschiedlichen Startjahren zumannhängen könnte, jedoch ändert auch die Anpassung der Fehlerwert-Tabelle nichts am Ergebnis.
Habt ihr noch Vorschläge, was ich probieren könnte?
Antwortento top
#9
Hi Remus,

wie gehabt: bitte zeige anhand einer Datei, was nicht richtig angezeigt wird. Vor allem mit deinen Formeln!
Gruß Günter
Jeder Fehler erscheint unglaublich dumm,
wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#10
Oh, bitte entschuldigt.
Arbeitsblatt mit dem Namen 'Angermuende'
ABCDEFGHIJKLMNOPQRSTUVW
1STATIONS_IDMESS_DATUMQN_3FXFMQN_4RSKRSKFSDKSHK_TAGNMVPMPMTMKUPMTXKTNKTGKeorFMRSKSDK
216419470101#NV#NV#NV5#NV#NV#NV#NV#NV4,11015,4-383-2-4#NVeor1940000
316419470102#NV#NV#NV5#NV#NV#NV#NV#NV3,91019-3,882-2,4-5#NVeor1941000
416419470103#NV#NV#NV5#NV#NV#NV#NV#NV3,31028,6-5,981-3,5-8#NVeor1942000
516419470104#NV#NV#NV5#NV#NV#NV#NV#NV1,61033,6-12,872-7,6-15,8#NVeor1943000
616419470105#NV#NV#NV5#NV#NV#NV#NV#NV1,31028,2-15,472-11,4-17,7#NVeor1944000
716419470106#NV#NV#NV5#NV#NV#NV#NV#NV1,21022,3-16,977-13,3-19,8#NVeor1945000
816419470107#NV#NV#NV5#NV#NV#NV#NV#NV1,61017-14,880-11,5-18,5#NVeor1946000
916419470108#NV#NV#NV5#NV#NV#NV#NV#NV1,61017,5-15,584-10,6-19,5#NVeor1947000
1016419470109#NV#NV#NV5#NV#NV#NV#NV#NV21013,8-10,374-8,2-15,8#NVeor1948000
1116419470110#NV#NV#NV5#NV#NV#NV#NV#NV2,11013,6-11,880-8-15,2#NVeor1949000
1216419470111#NV#NV#NV5#NV#NV#NV#NV#NV1,51011,4-15,280-8,6-20,4#NVeor1950000

ZelleFormel
U2=SUMMENPRODUKT(ISTNV($E$1:$E$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T2;"@")))
V2=SUMMENPRODUKT(ISTNV($G$1:$G$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T2;"@")))
W2=SUMMENPRODUKT(ISTNV($I$1:$I$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T2;"@")))
U3=SUMMENPRODUKT(ISTNV($E$1:$E$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T3;"@")))
V3=SUMMENPRODUKT(ISTNV($G$1:$G$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T3;"@")))
W3=SUMMENPRODUKT(ISTNV($I$1:$I$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T3;"@")))
U4=SUMMENPRODUKT(ISTNV($E$1:$E$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T4;"@")))
V4=SUMMENPRODUKT(ISTNV($G$1:$G$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T4;"@")))
W4=SUMMENPRODUKT(ISTNV($I$1:$I$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T4;"@")))
U5=SUMMENPRODUKT(ISTNV($E$1:$E$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T5;"@")))
V5=SUMMENPRODUKT(ISTNV($G$1:$G$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T5;"@")))
W5=SUMMENPRODUKT(ISTNV($I$1:$I$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T5;"@")))
U6=SUMMENPRODUKT(ISTNV($E$1:$E$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T6;"@")))
V6=SUMMENPRODUKT(ISTNV($G$1:$G$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T6;"@")))
W6=SUMMENPRODUKT(ISTNV($I$1:$I$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T6;"@")))
U7=SUMMENPRODUKT(ISTNV($E$1:$E$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T7;"@")))
V7=SUMMENPRODUKT(ISTNV($G$1:$G$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T7;"@")))
W7=SUMMENPRODUKT(ISTNV($I$1:$I$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T7;"@")))
U8=SUMMENPRODUKT(ISTNV($E$1:$E$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T8;"@")))
V8=SUMMENPRODUKT(ISTNV($G$1:$G$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T8;"@")))
W8=SUMMENPRODUKT(ISTNV($I$1:$I$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T8;"@")))
U9=SUMMENPRODUKT(ISTNV($E$1:$E$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T9;"@")))
V9=SUMMENPRODUKT(ISTNV($G$1:$G$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T9;"@")))
W9=SUMMENPRODUKT(ISTNV($I$1:$I$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T9;"@")))
U10=SUMMENPRODUKT(ISTNV($E$1:$E$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T10;"@")))
V10=SUMMENPRODUKT(ISTNV($G$1:$G$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T10;"@")))
W10=SUMMENPRODUKT(ISTNV($I$1:$I$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T10;"@")))
U11=SUMMENPRODUKT(ISTNV($E$1:$E$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T11;"@")))
V11=SUMMENPRODUKT(ISTNV($G$1:$G$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T11;"@")))
W11=SUMMENPRODUKT(ISTNV($I$1:$I$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T11;"@")))
U12=SUMMENPRODUKT(ISTNV($E$1:$E$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T12;"@")))
V12=SUMMENPRODUKT(ISTNV($G$1:$G$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T12;"@")))
W12=SUMMENPRODUKT(ISTNV($I$1:$I$28000)*(LINKS($B$1:$B$28000;4)=TEXT(T12;"@")))
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Bei der vorherigen Tabelle, die bei 2011 beginnt, funktionieren die kopierten Formeln.
Liegt es daran, dass teils bei manchen Parametern ganze Jahre an Werten fehlen? Aber dann müsste ja 365 in den Zellen stehen, oder irre ich mich da?
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste