Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Zählenwenns Kalenderwoche ohne Wochenende
#1
Hallo,

ich ziehe aus unserem Programm die Uraubstage unserer Mitarbeiter in Excel herunter. Hier möchte ich einen Urlaubsplaner auf Kalenderwochen 1-52 machen.

Vom Programm bekomme ich den Namen und das Datum. (im Programm werden die Urlaubswochen über das Wochenende angelegt, d.h. ich habe bei längeren Urlauben immer die Wochenenden mit drinstehen)
Anhand von dem Datum ermittle ich die Kalenderwoche.
Dann habe ich in meinem Urlaubsplaner die "Zählenwenns"-Funktion, die mir die Anzahl der Datums pro Mitarbeiter je Kalenderwochen in der jeweiligen Kalenderwoche ausweist.
So kommt es, dass in manchen Kalenderwochen die 2, 3 oder 5 steht, leider kommt auch die 7 (wegen Samstag/Sonntag)

Wie kann ich die Ermittlung der Anzahl der Datums auf 5 begrenzen?
Antworten Top
#2
Hallo,

Zitat:Wie kann ich die Ermittlung der Anzahl der Datums auf 5 begrenzen?

offenbar gar nicht, sonst hättest du nicht gefragt.  Blush Zeige doch mal, was du schon hast (Beispieldatei), dann passen die Lösungsvorschläge zu deiner datei.
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antworten Top
#3
Hallo,

wenn du das Tagesdatum hast, kannst du mit Wochentag() den Tag der Woche (1 bis 7) ermitteln. 

In einer Summenprodukt() Formel verpackt, zählst du dann die Urlaubstage, die auf einen Wochentag kleiner 6 fallen.

Beispieltabelle für konkrete Vorschläge wäre hilfreich.
Cadmus
Antworten Top
#4
Scheint mir konzeptuell ziemlich problematisch: ein Kalenderwoche ohne Wochen'ende'. 19
Zum übersetzen von Excel Formeln:

http://dolf.trieschnigg.nl/excel/index.p...gids=en+de
Antworten Top
#5
Hier mal eine Beispieldatei. 

Bei Meier, darf die 7 nicht stehen bleiben, sondern muss die 5 ausweisen. 

GIbt es eine andere Formel als die Kalenderwoche, mit der ich die Anzahl der Urlaubstage je Kalenderwoche ermitteln kann, wenn ich das Wochenende nicht ausschließen kann?


Angehängte Dateien
.xlsx   Urlaubsplan 2024 test.xlsx (Größe: 17,48 KB / Downloads: 6)
Antworten Top
#6
Hola,
Code:
=SUMMENPRODUKT((Daten!$A$2:$A$60=$A5)*(Daten!$F$2:$F$60=C$3)*(WOCHENTAG(Daten!$C$2:$C$60;2)<6))
Gruß,
steve1da
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste