Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Werte nach Doppelt-Prüfung duplizieren
#1
Hallo,

ich habe ein Problem. In der beliegenden Exceltabelle sollen nach einer Prüfung der Spalte A (gibt es doppelte) die Werte aus Spalte C in die Spalte D - G geschrieben werden. Das heißt, wenn es keinen doppleten Wert in Spalte A gibt, soll der Wert aus Spalte C in Spalte D geschrieben werden. Ist Spalte A doppelt, soll der 2. Wert in Spalte E geschrieben, u.s.w. Könnt Ihr mir helfen?  Danke


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#2
(03.04.2020, 15:20)RaGe77 schrieb: Könnt Ihr mir helfen?

Vielleicht könnte man Dir helfen.
Allerdings gibt es wirklich keinen vernünftigen Grund, dies zu tun!
Schließlich hast Du bereits eine Liste, die auswertbar ist.
Die von Dir angedachte Kreuztabelle mag Dir sinnvoll erscheinen (schließlich werden seit Äonen Stundenpläne so [in der Druckform] erstellt), auswertbar ist so etwas jedoch nur über zig Umwege.

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#3
Das kann man mit einem Makro lösen.

Da kann ich Dir helfen:

Einfach Zeile für Zeile durchgehen und den von Dir beschriebenenen Vorgang durchführen.

LGR
Antwortento top
#4
Hallo,

nochmals zum Verständnis. Der erste Wert ist immer der Kommen Wert. Sollte es einen doppelten Wert geben, ist es ein Gehen Wert. Der nächste doppelte Wert ist wiederum der nächste Kommen Wert, u.s.w.

Am Ende müssen wir die Anwesenheitsminuten berechnen. Ich habe es mit einer Formel nicht hinbekommen, in einer Formel die Doppeltprüfung und die Berechnung der Anwesenheitsminuten zu berechnen.

Deswegen war ich der Meinung, wenn es in einer Zeile steht, ist die Berechnung einfacher. Leider bekommen wir die Daten auch nur so geliefert...
Antwortento top
#5
Hallöchen,

im Prinzip so. Die Formel aus D1 über den Bereich kopieren.

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDE
115157
226268
317
428

ZelleFormel
D1=WENNFEHLER(INDEX($B$1:$B$4;AGGREGAT(15;6;ZEILE($A$1:$A$4)/(($A$1:$A$4=$C1));SPALTE()-3);1);"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste