Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Werte aus großer Pivottabelle anzeigen
#1
Hallo zusammen, ich habe eine ziemlich große Pivottabelle vor mir liegen mit circa. 500 Kostenstellen (X-Achse/Spalten) und circa 5000 Dienstleistern (Y-Achse/Zeilen).

Die Tabelle zeigt, wie viele Buchungen von welchem Dienstleister auf die jeweiligen Kostenstellen durchgeführt werden.
Da die Tabelle extrem groß & somit unübersichtlich ist, würde ich gerne auf einem Zweiten Sheet mir eine Zusammenfassung ziehen.
Diese soll am besten für alle Dienstleister auflisten, wie viele Belege gesamt gebucht wurden und dann die Top15/Top20 Kostenstellen auflisten, mit den meisten Buchungen. Ich habe ein Beispiel, wie es am besten aussehen könnte mal als Anhang hinzugefügt.

Könnt ihr mir da irgendwelche Vorschläge/Lösungen nennen?

Danke und VG,
Arny


.xlsx   Excel_Beispiel.xlsx (Größe: 9,57 KB / Downloads: 8)
Antwortento top
#2
Hi

für deine Bsp.Datei

A10   =WENN(A2="";"";A2)       nach unten ziehen
B10   =WENNFEHLER(AGGREGAT(14;6;$B2:$AA2;SPALTE(A1));"")       nach rechts und unten ziehen

Gruß Elex
Antwortento top
#3
Danke für deine Antwort! Die zweite Formel sieht schon ganz cool aus.
Ich steh wahrscheinlich gerade aufm Schlauch, aber was genau macht die erste Formel nochmal?
Überträgt sie einfach alle Dienstleister von der Originaltabelle in die neue Tabelle in dem neuen Sheet?

LG
Antwortento top
#4
Ich habe das mit den Power Pivot Mitteln gelöst, sieht dann so aus
   
Antwortento top
#5
@Warkings
kannst du mir sagen, wie du das gemacht hast? Kenne mich mit pivottabellen leider überhaupt nicht aus.
Und bei dir wird ja angzeigt, welche KST wie viele Buchungungen auf dem jeweiligen Dienstleister hat, korrekt?




@Elex
Ich hab leider vergessen zu erwähnen/im Beispiel zu zeigen, aber wie müsste ich die Formeln anpassen, um in der zweiten Tabelle nicht nur die Anzahl der Buchungen zu sehen, sondern auch ersichtlich wird, welche Kostenstelle bspw. auf Platz 1,2 oder 3 liegt. Könnte man da nicht mit einer Verkettung arbeiten?
Antwortento top
#6
Ich hätte leiber die Rohdaten worauf die Pivottabelle basiert ist.
Zum übersetzen von Excel Formeln:

http://dolf.trieschnigg.nl/excel/index.p...gids=en+de
Antwortento top
#7
@snb: Genau, so habe ich es nämlich gemacht. Mir ein paar Beispieldaten gebaut und dann daraus das Ergebnis erzeugt.
Antwortento top
#8
Hi Arny

Zitat:Ich hab leider vergessen zu erwähnen/im Beispiel zu zeigen, aber wie müsste ich die Formeln anpassen, um in der zweiten Tabelle nicht nur die Anzahl der Buchungen zu sehen, sondern auch ersichtlich wird, welche Kostenstelle bspw. auf Platz 1,2 oder 3 liegt. Könnte man da nicht mit einer Verkettung arbeiten?
Mein Idee dazu wäre diese.

.xlsx   Excel_Beispiel.xlsx (Größe: 16,43 KB / Downloads: 3)

Gruß Elex
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste