Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Wert aus Zelle in einer sortierten Liste suchen und Rang ausgeben
#1
Hallo!

Ich hoffe,  mir kann Jemand helfen.

Ich habe eine sortierte Liste mit Namen und erzielten Punkten. Diese Liste ist absteigend nach den Punkten sortiert. 

Nun möchte ich eine Suche oder Abfrage machen,  an welcher Position  (Rang) sich eine neuer Name mit seiner Punktzahl einreihen würde!

Bsp. Bestenliste
         Name1= 10 Punkte (1.Platz)
         Name3=  8 Punkte (2. Platz)
         Name2=  5 Punkte (3. Platz)

Nun hat Name4 = 7 Punkte erzielt. Durch die Abfrage oder Suche möchte ich nun in einer Zelle den möglichen Rang bzw. die Position ausgegeben haben, wo sich Name4 (mit seinen 7 Punkten) einreihen würde.
Das wäre sozusagen Platz/Rang 3.

Geht das?

Ich möchte nämlich per VBA einen Button einbauen, wo man entscheiden kann, ob z.B. Name4 mit seinen 7 Punkten in die bestehen Bestenliste eingetragen werden soll oder nicht. Wenn der Name4 eingetragen werden soll, dann steht er durch seine Punktzahl  (7) nun an der 3. Position und Name2 (5 Punkte) rutscht auf den Platz 4.

Danke

P.S. Es soll sozusagen ein Wert (aus einer Zelle) überprüft werden, an welcher Position bzw.welchen Rang dieser Wert wäre.
Antwortento top
#2
Hallo Redgeier,

z.B. mit der Funktion ZÄHLENWENN:

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEF
1NamePunkteRangName4
2Name1101Punkte:7
3Name282Rang:3
4Name353
5Name434

ZelleFormel
F3=ZÄHLENWENN($B$2:$B$4;">"&F2)+1
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Gruß
Fred
Antwortento top
#3
Perfekt!

Danke Fred!
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste