Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Wenn mit Sverweis Kombination
#1
Question 
Hallo,

ich habe eine Zeiterfassungstabelle und wollte nun automatisch die Feiertage als F jeweils hinter das entsprechende Datum setzen. Um dann mit einer Wenn Funktion die Sollzeit auf 0 zu setzen.

Folgende Formel habe ich verwendet

Code:
=WENN(SVERWEIS(A5;$A$44:$A$57;1;0);"F";"")

Bei dem 01.01. klappt es. Bei den anderen Tage erhalte ich nur die Meldung NV

Einmal ein kurzer Ausschnitt der Arbeitsmappe im Anhang 

Liebe Grüße Blush


Angehängte Dateien
.xlsx   Beispieltabelle.xlsx (Größe: 10,51 KB / Downloads: 3)
Antwortento top
#2
Moinsen,

Sverweis:
Code:
=WENN(ISTFEHLER(SVERWEIS(A5;$A$44:$A$57;1;0));"";"F")

Verweis:
Code:
=WENN(ISTFEHLER(VERGLEICH(A5;$A$44:$A$56;0));"";"F")
gruß
Marco
[-] Folgende(r) 1 Benutzer sagt Danke an Mase für diesen Beitrag:
  • Pflüg177
Antwortento top
#3
Hola,


Code:
=WENN(ZÄHLENWENN(Tabelle1!$A$44:$A$57;A5);"F";"")

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • Mase
Antwortento top
#4
Super, das hat gut geklappt. Angel

Und wie ist das mit den Ferienzeiten? Kann man dies auch mit einer von bis Tabelle machen?
Antwortento top
#5
Hola,

da in der Datei keinerlei Ferienzeiten enthalten sind kann man ein deutliches JaNeinVielleicht antworten.

Gruß,
steve1da
Antwortento top
#6
Das der dann quasi auch Frei anzeigt wenn Ferien sind

Außerdem versuche ich die Sollzeit automatisch einzufügen. Die Person arbeitet Montags+Dienstags 6 Stunden und Freitag 4.
Ich habe es schon mit einer Wenn Formel versucht (Siehe Beispieltabelle) aber da ist glaub ich ein fehler drin. Es wird leider nichts angezeigt Huh
Und wenn eventuell Frei ist (also F), das dann auch keine Sollzeit angezeigt wird



Vielen dank für die Hilfe Sleepy


Angehängte Dateien
.xlsx   Beispiel.xlsx (Größe: 14,46 KB / Downloads: 1)
Antwortento top
#7
Hola,


Code:
=WENN(ODER(ZÄHLENWENN($A$44:$A$57;A5);ZÄHLENWENNS($A$60:$A$65;"<="&A5;$B$60:$B$65;">="&A5));"F";"")


Code:
=WENN(WOCHENTAG(A5;2)<3;6/24;WENN(WOCHENTAG(A5;2)=5;4/24;""))

Gruß,
steve1da
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste