Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Wenn Und Formel
#1
Hi,

komme leider nicht weiter:
Habe in der Zelle D1 stehen:

=WENN(UND(A1=“x“;B1=“y“;C1=“z“);PPGGEE;“nichts“)

Es kommt aber der Fehler #NAME?

Was aber noch ist, wäre Schritt 2
In den Zellen kann folgendes stehen:
A1=x,a,t,r
B1=y,b,e,f
C1=z,c,w,h

D1=dann alle Varianten aus A1-C1 mit vorgegebenen Werten.

Gruss
Face
Antwortento top
#2
Hi,

lad mal bitte eine Beispieltabelle (.xlsx - keine Bildchen!!) mit allen möglichen Varianten hoch. https://www.clever-excel-forum.de/Thread...ng-stellen
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
Hallo,

PPGGEE ist nicht in "" bzw. kein benannter Bereich.
Cadmus
Antwortento top
#4
Hola,

außerdem mag Excel keine kursiven ""

Gruß,
steve1da
Antwortento top
#5
D1: =WENN(A1&B1&C1="xyz";"PPGGEE";"nichts")
Antwortento top
#6
Hi @all,

super das passt
=WENN(A1&B1&C1="xyz";"PPGGEE";"nichts")

und wie wenn mehrere Werte in den Zellen zulässig sind?
Antwortento top
#7
Hi,

was genau meinst du damit?
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#8
Hi Günter,

In den Zellen kann folgendes stehen:
A1=x,a,t,r
B1=y,b,e,f
C1=z,c,w,h


so nun möchte wenn in den Zellen
A1-C1 x,b,c steht in Zelle D1 = Sonnentag schreiben
A1-C1 x,e,h steht in Zelle D1 = Laubfrosch schreiben

und immer so weiter bis alle Varianten durchgespielt sind.

Habe was in VBA gefunden, aber das bezog sich auf Spalten:


Code:
Sub ElseDemo2()

    ' Get the data range
    Dim rg As Range
    Set rg = shMarks.Range("A1").CurrentRegion
   
    ' Clear existing classifications
    rg.Columns(5).Offset(1).Cells.ClearContents
   
    Dim i As Long, marks As Long, class As String
    ' Go through the marks columns
    For i = 2 To rg.Rows.Count
       
        ' Get the marks
        marks = rg.Cells(i, 3).Value & rg.Cells(i, 4)
                   
        ' check the marks using if and ElseIf
        If marks >= Sonnen König Then
            class = "Frankreich"
        ElseIf marks >= Pasta Teller Then
            class = "Italien"
        ElseIf marks >= Brat Wurst Then
            class = "Deutschland"
        ElseIf marks >= Essen ToGo Then
            class = "USA"
        Else
            ' All other marks
            class = "Fail"
        End If
       
        rg.Cells(i, 5).Value = class
    Next i
   
End Sub

Das wäre was in die Richtung.
Nur bekomme ich es nicht umgeschrieben auf die drei Zellen
marks = rg.Cells(i, 3).Value & rg.Cells(i, 4).Value & rg.Cells(i, 5).Value

dann schreibe in Zelle X100 den Class Wert

cu
Antwortento top
#9
Hi,

ich erinnere an #2 (Beispieltabelle). Gerne darfst du sensible Daten anonymisieren; der Sinn des Vorhabens und der Aufbau deiner Tabelle muss aber zwingend deinem Original gleichen.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#10
D1: =SVERWEIS(A1&B1&C1;X$1:Y$64;2;)

mit

X1:Y64:

abc leckmi
abh omorsch
...
xyz oldetrump
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste