Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Wenn Uhrzeit Spalte 2, dann name Spalte 1 ausgeben
#1
Guten Morgen zusammen,

[url=Dateiupload bitte im Forum - wie's geht: http://www.clever-excel-forum.de/thread-326.html .]

[img]Dateiupload bitte im Forum - wie's geht: http://www.clever-excel-forum.de/thread-326.html .]

Es geht um folgendes Problem:

Ich möchte auf einer weiteren Arbeitsmappe ein Feld erstllen, wo ich jeden angezeigt bekomme, bei dem z.B. 09:00 steht + passenden Namen rechts.

Heißt sowas wie: wenn C7-C42 = 09:00, dann zeig mir den passenden namen in AB7-42 an

gibt es da eine Möglichkeit?

Danke und liebe Grüße
Antwortento top
#2
Hallo Denis,

so in der Art?

Arbeitsblatt mit dem Namen 'Sheet2'
ABCDEFG
1BeginnEndeStdWer?Namen
207:0016:0009:00PeterPeter
307:3016:0008:30falsche ZeitFranz
408:0017:0009:00HugoHugo

ZelleFormel
D2=WENN(C2=9/24;G2;"falsche Zeit")
C2=B2-A2
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg

Falls nicht, lade bitte eine Beispieldatei - kein Bild - hoch. Wie das geht siehst du, wenn du den Link im Eröffnungsbeitrag öffnest.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm,
wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
(23.08.2019, 06:21)WillWissen schrieb: Hallo Denis,

so in der Art?

Arbeitsblatt mit dem Namen 'Sheet2'
ABCDEFG
1BeginnEndeStdWer?Namen
207:0016:0009:00PeterPeter
307:3016:0008:30falsche ZeitFranz
408:0017:0009:00HugoHugo

ZelleFormel
D2=WENN(C2=9/24;G2;"falsche Zeit")
C2=B2-A2
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg

Falls nicht, lade bitte eine Beispieldatei - kein Bild - hoch. Wie das geht siehst du, wenn du den Link im Eröffnungsbeitrag öffnest.


Schonmal vielen lieben Dank für die Antwort.

Es sieht eher so aus:  (siehe Datei)

Da möchte ich, dass der in einer extra Spalte (bzw. einer weiteren Arbeitsmappe) jeden Namen anzeigt, bei dem 09:00 steht.


Angehängte Dateien
.xlsx   Mappe1.xlsx (Größe: 10,02 KB / Downloads: 5)
Antwortento top
#4
HAllöchen,

Du musst noch rechts auf "Attachment hinzufügen" klicken. Links wählst DU nur die Datei … Und bitte nicht den ganzen Beitrag zitieren, es gibt auch "Antworten" Smile
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#5
Sorry, mein Fehler 20

Gesagt getanSmile danke!
Antwortento top
#6
Hallöchen,

sollte in C1 09:00 stehen oder in C2 links 09:00 ?
Die Nullen kommen, weil bei Dir in Spalte AB nix steht 17 . Oder meinst Du, wie im Betreff, die verbundenen Zellen Spalte A & B? Dann reicht in der Formel statt AB2 dann A1

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEAB
1S(41) A607:1016:10Wenn Spalte C 09:00 , Dann Name aus Spalte AB
209:00/13:00-13:3000:300
3G (41) A607:1016:10
409:00/13:00-13:3000:300

ZelleFormel
E2=WENN(LINKS(C2;5)="09:00";AB2;"")
E3=WENN(LINKS(C3;5)="09:00";AB3;"")
E4=WENN(LINKS(C4;5)="09:00";AB4;"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.1) erstellt. ©Gerd alias Bamberg

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDE
1S(41) A607:1016:10Wenn Spalte C 09:00 , Dann Name aus Spalte AB
209:00/13:00-13:3000:30S(41) A6
3G (41) A607:1016:10
409:00/13:00-13:3000:30G (41) A6

ZelleFormel
E2=WENN(LINKS(C2;5)="09:00";A1;"")
E3=WENN(LINKS(C3;5)="09:00";A2;"")
E4=WENN(LINKS(C4;5)="09:00";A3;"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.1) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#7
Hallo Denis,

das ist ein total verkorkster Aufbau. Was willst du denn überhaupt darstellen?


Zitat:09:00/13:00-13:30

Das ist keine Uhrzeit, sondern Text und verlangt zum Auslesen völlig unnötige Verrenkungen. Desgleichen sind verbundene Zellen in meinen Augen Murks und habe in Tabellen, aus denen ausgewertet werden soll, nichts verloren.

Lies dir doch mal die Beiträge hinter diesen Links durch:
https://www.clever-excel-forum.de/Thread...oder-Segen
https://www.online-excel.de/excel/singsel.php?f=52
Gruß Günter
Jeder Fehler erscheint unglaublich dumm,
wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#8
Hallo,

ich finde es auch nicht optimal, es stellt im Prinzip eine vorhandene, aber nicht gezählte Pause dar

um 09:00 ist eine 20 minütige Pause, diese wird aber nicht mitgezählt, daher per Hand eingetippt

umd 13.00 - 13.30 ist dann die reguläre gezählte Pause.

Finde den Aufbau auch suboptimal und würde lieber eine weitere Zeile anwenden, damit es netter aussieht, habe aber aus platztechnischen Gründen drauf verzichtet (die Tabelle geht noch weiter nach rechts und nach unten)

Die 2 Zeilen beim Namen sind einfach nur Verbunden, damit es schöner aussieht

solltest du dafür einen Tipp haben oder sagen, dass es egal ob zu wenig platz oder nicht, es trotzdem mehr sinn macht weitere zeilen einzufügen (damit die Formeln einfacher sind) würde ich das berücksichtigen und ändern.

Ansonsten, bin ich echt ein ziemlicher Anfänger mit Excel und verscuhe mich momentan zu verbessern und durchzukämpfen
Antwortento top
#9
Hi Denis,


Zitat:und würde lieber eine weitere Zeile anwenden, damit es netter aussieht, habe aber aus platztechnischen Gründen drauf verzichtet (die Tabelle geht noch weiter nach rechts und nach unten)

hmm, in deiner Excelversion hast du ja nur knapp 1,05 Mio Zeilen und 16.384 Spalten. Da ist es schon klar, dass man ein wenig sparen muss. Angel

Ich rate dir, schau dich mal hier im Forum unter dem Stichwort Arbeitszeit, Arbeitszeitberechnung usw. um oder befrage einmal Tante Gugl oder Onkel Bing nach diesen Begriffen. Du findest unter Garantie zig Vorlagen, aus denen du eine ordentliche Tabelle nach deinen Bedürfnissen erstellen kannst. Und wenn du dann nicht weiterkommst, weißt du, wo du nachfragen kannst. Wink
Gruß Günter
Jeder Fehler erscheint unglaublich dumm,
wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#10
Hallöchen,

Zitat:damit die Formeln einfacher sind

so kompliziert sind meine doch nicht, oder? Wenn Du Dich im Forum umschaust, wirst Du Formeln entdecken, die über mehrere Zeilen gehen 22

Zitat: habe aber aus platztechnischen Gründen drauf verzichtet

16.384 Spalten wirst Du natürlich nicht auf einmal gut lesbar auf den Bildschirm bekommen geschweige denn auf ein A4 - Blatt, nicht mal im Querformat 20 Aber eventuell musst Du das auch gar nicht 05
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste