Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Wenn Feiertag oder Sonntag sollte 0 ausgegeben werden
#1
Hallo Zusammen, 

ich hab ein folgendes Problem:
in Excel sollte 0 ausgegeben werden, wenn der Tage der Woche ein Sonntag oder ein Feiertag ist. 
Für Sonntag hat es mit folgender Funktion geklappt: 
=WENN(WOCHENTAG(I31:I61)=1;"0";GANZZAHL((O3/E58)))

Ich hab es für Feiertage wie folgt versucht, es kommt aber eine Fehlermeldung
=WENN(ODER(WOCHENTAG(I31:I61)=1;(I31:I61)=Feiertage!C23:C35);"0";GANZZAHL((O3/E58)+J65))

In der Tabelle Feiertage sind alle Feiertag in Deutschland aufgelistet, I31:I61 sind die Kalendertage von Mai. 

Weißt jmd wo der Fehler liegt 22 22 22 22 ?

Danke !!
Antwortento top
#2
Hi,

stell bitte eine Beispieltabelle (https://www.clever-excel-forum.de/thread-326.html) zur Verfügung; ich mag nach deiner Beschreibung zum Testen keine Tabelle nachbauen.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.zitate.net
Antwortento top
#3
Hi, 

ich hänge hier die Tabelle an. 

Vielen Dank!


Angehängte Dateien
.xlsx   Forum frage.xlsx (Größe: 26,78 KB / Downloads: 12)
Antwortento top
#4
Hola,

Code:
=WENN(ODER(WOCHENTAG(I31;2)=7;ZÄHLENWENN(Feiertage!$C$23:$C$35;I31));0;GANZZAHL((O3/E58)+J65))

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • dominiczka0713
Antwortento top
#5
Hallo,

geht doch auch mit =NETTOARBEITSTAGE.INTL(I31;I31;11;C23:C35) man setzt dann nur Startdatum = Enddatum

Oder bin ich da falsch ?
VG Sabina

bei mir läuft Win 7 32-Bit - Office 2010 Pro Plus 32-Bit und Office 2016 Pro Plus 32-Bit
Wer auch weiter Hilfe erwartet, sollte sich nicht zu schade sein, ein kurzes Feedback zu geben.
Antwortento top
#6
Hallo,

@Sabina: Fast. Lass das Netto am Anfang und das e am Ende weg:
Code:
=(ARBEITSTAG.INTL(I31-1;1;"0000001";Feiertage!$C$23:$C$35)=I31)*$O$3/$E$58
Gruß
Michael
Antwortento top
#7
Hallo Michael,

... heute nörgeln erst mal alle an mir rum ... bin total genervt. Erklärst du mir bitte deinen Verriß ... 22

Meine Formel bringt eine 0 - falls es ein Sonntag oder ein Feiertag ist und sie bringt eine 1, falls es ein Werktag ist.
Zieht man sie runter, bringt sie das für den gesamten Bereich. Mehr hat der TE nicht angefragt !!!

... was der TE mit GANZZAHL((O3/E58)+J65)) bezweckt ... ??? ... hab ich in der Datei nichts sinnvolles dazu gefunden.
Außerdem wird er das noch selbst hinkriegen. 

Also warum bitte ??? Dodgy
VG Sabina

bei mir läuft Win 7 32-Bit - Office 2010 Pro Plus 32-Bit und Office 2016 Pro Plus 32-Bit
Wer auch weiter Hilfe erwartet, sollte sich nicht zu schade sein, ein kurzes Feedback zu geben.
[-] Folgende(r) 1 Benutzer sagt Danke an Flotter Feger für diesen Beitrag:
  • Klaus-Dieter
Antwortento top
#8
Hallo Sabina,

entschuldige bitte, ich wollte doch nicht nögeln oder Deinen Beitrag verreissen. Du hast natürlich recht, Dein Vorschlag funktioniert genauso, ich habe nicht genau hingesehen. 15 Wieder Freunde?
Gruß
Michael
[-] Folgende(r) 1 Benutzer sagt Danke an Der Steuerfuzzi für diesen Beitrag:
  • Flotter Feger
Antwortento top
#9
Hallo Michael,

... na klar ... alles gut. 17
Hat heute nur total ins Bild gepasst ... sorry, für meine Ausdrucksweise.
VG Sabina

bei mir läuft Win 7 32-Bit - Office 2010 Pro Plus 32-Bit und Office 2016 Pro Plus 32-Bit
Wer auch weiter Hilfe erwartet, sollte sich nicht zu schade sein, ein kurzes Feedback zu geben.
Antwortento top
#10
Kein Problem, ich halte das schon aus. Hattest ja auch recht. Und manchmal muss es halt einfach mal raus Wink
Gruß
Michael
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste