Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Wenn Datum, dann Text aus Zellenbereich
#1
Liebe Community,

ich bastele nun seit Tagen an einer Formel, um mir in Spalte A den Feiertagsnamen ausgeben zu lassen, wenn in Spalte B das entsprechende Datum steht, sonst soll der Monatsname ausgegeben werden.
Auf die Feiertage habe ich bereits eine bedingte Formatierung gesetzt mit einem S-Verweis (grüne Füllung, roter Text).
Die Feiertagsnamen stehen in Spalte N und deren jeweiliges Datum in Spalte P, wobei das Datum über die Osterformel berechnet wurde.
Jetzt möchte ich, dass Excel guckt, ob in Spalte B eines der Daten aus dem Bereich P7 bis P20 vorkommt, dann soll es aus diesem Bereich den Text aus der Spalte davor (N -> Feiertagsname) in der Zielzelle (A) ausgeben. Wenn diese Bedingung nicht erfüllt ist, es sich also um keinen Feiertag handelt, soll es als Text den Monatsnamen hinschreiben.
Ich habe schon alles mögliche versucht, aber ich komme einfach zu keinem Ergebnis.

Hoffe auf Eure Hilfe.

LG Sandra


Ergänzung:

Damit habe ich es versucht:

=WENN(ISTFEHLER(SVERWEIS(B4:B368;P7:P20;1;FALSCH));"Januar";N$7:N$20)

=WENNFEHLER(SVERWEIS($A4;$P$7:$P$20;1;FALSCH);N7:N20)
Antwortento top
#2
Könntest Du die bisherigen Fragen in diesem Forum oder zu anderen Foren verlinken? Das gebietet der Anstand.

Ich mag nicht mehr suchen - ich weiß nur, dass Sandra Feiertage sucht.
Antwortento top
#3
Oh tut mir leid, wenn ich was falsch gemacht habe. Aber ich habe dich jetzt nicht verstanden Huh . Was genau soll ich verlinken?
Antwortento top
#4
Die Stelle, wo Du schon gefragt hast. Und von dort genauso hierher, also umgekehrt.
Antwortento top
#5
Ach so... Meinst du das?

http://www.office-loesung.de/p/viewtopic.php?f=166&t=821446

Hier übrigens die Datei:


.xlsx   Mappe1 - Kopie.xlsx (Größe: 24,7 KB / Downloads: 7)
Antwortento top
#6
Moin


Code:
=WENNNV(INDEX($N$7:$N$20;VERGLEICH(B4;$P$7:$P$20;0));TEXT(B4;"MMMM"))
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#7
Oh perfekt, genau so, vielen lieben Dank 87
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste