Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Wenn-Dann-Wenn-Dann???
#1
Servus zusammen,

leider scheitere ich an einer Formel. Ich habe mehrere Abfragen hintereinander gestellt und irgendwann macht Excel dicht.

Die Formel lautet:

=WENN(E5<=2;(WENN(D5=1;'Dienstzeiten 5,0'!$C$2;(WENN(E5<=2;(WENN(D5=2;'Dienstzeiten 5,0'!$C$3;(WENN(E5<=2;(WENN(D5=3;'Dienstzeiten 5,0'!$C$4;(sollte wenn möglich hier eingebettet werden)))))))))))

Das funktioniert soweit ganz gut...
Jetzt soll aber das ganze auch für E5>=3 erstellt werden und da schmeißt er permanent einen Fehler aus.

Wäre dankbar für eine Lösung.
Antwortento top
#2
Hola,

und die Fehlermeldung lautet?

Leg dir eine Referenztabelle an und hol dir die Werte per Sverweis:
https://www.online-excel.de/excel/singsel.php?f=9

Gruß,
steve1da
Antwortento top
#3
Schaue ich mir gerne an. Vielen Dank
Antwortento top
#4
Hi,


nach dem Motto:

Code:
=wenn(E5=2;Index('Dienstzeiten 5,0'!C:C;Verweis(D5;{1;2;3;4};{2;3;4;5}))
=wenn(E5=2;Index('Dienstzeiten 5,0'!C:C;min(5;D5+1))
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste