Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

WAHL in SVERWEIS
#1
Hallo,
ich möchte eine SVERWEIS-Funktion erstellen. Sie enthält eine WAHL-Funktion und ich möchte innerhalb eines anderen Tabellenblattes "wählen" lassen, was nicht so richtig funktioniert (WAHL lässt den Bezug zum anderen Blatt so nicht zu)

=SVERWEIS(("*" & A2 ) & (B2 & "*");WAHL({1.2};Benotung!D5:D93&D5:D93;E5:E93);2;FALSCH) führt zu "NV!"

Auf dem 1. Blatt habe ich je eine Spalte für Nachname (A) und Vorname (B)
Auf meinem Blatt "Benotung" habe ich eine Spalte mit "Nachname, Vorname" (D) und eine Spalte mit der ID (E), welche ich ausgegeben haben möchte.
WAHL lässt mich den Verweis "Benotung!" nicht einfügen.

Was kann ich tun? 

LG legrohm  Blush
Antwortento top
#2
INDEX und VERGLEICH statt dessen verwenden. SVERWEIS ist arg beschränkt und hat keinen Vorteil.
Antwortento top
#3
Hallo legrohm,

probier mal:
Code:
=SVERWEIS(A1&", "&B1;Tabelle1!A:B;2;0)
(die Bezüge natürlich auf Deine Tabelle anpassen)

Gruß,
Lutz
Antwortento top
#4
Hallo,

als erstes wäre mal zu klären, was Du genau machen willst. Denn Deine Ausführungen sind mehr als unverständlich:
(02.10.2020, 10:18)legrohm schrieb: ich möchte innerhalb eines anderen Tabellenblattes "wählen" lassen
Was willst Du denn wählen lassen?

Deine Formel sucht nach dem (zusammengesetzten) Wert in der Tabelle Benotung D5:D93 verknüpft mit dem Bereich D5:D96 des aktuellen Tabellenblatts (in dem die Formel steht). Möglicherweise liegt hier schon der Fehler? Denn #NV deutet daruf hin, dass we Wert nicht gefunden werden konnte (Suchbegriff falsch üder Matrix falsch).

(02.10.2020, 10:18)legrohm schrieb: Auf dem 1. Blatt habe ich je eine Spalte für Nachname (A) und Vorname (B)
Auf meinem Blatt "Benotung" habe ich eine Spalte mit "Nachname, Vorname" (D) und eine Spalte mit der ID (E), welche ich ausgegeben haben möchte.
WAHL lässt mich den Verweis "Benotung!" nicht einfügen.
Diese Ausführungen passen nicht zum "auswählen" des Tabellenblatts. Wenn ich Dich richtig verstehe muss hier nichts ausgewählt werden und diese Formel sollte reichen:
Code:
=SVERWEIS(A2&", "&B2;Benotung!D5:E93;2;FALSCH)
Gruß
Michael
Antwortento top
#5
Danke euch allen für eure Antworten.


Zitat:=SVERWEIS(A2&", "&B2;Benotung!D5:E93;2;FALSCH)


funktioniert.

Klassischer Fall von zu kompliziert gedacht.  
Lieben Gruß und schönes Wochenende
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste