Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Verketten von zwei Formeln
#1

.xlsx   Beispiel.xlsx (Größe: 21,13 KB / Downloads: 7) Hallo zusammen,

ich versuche gerade eine Auswertung mithilfe von Excel Formeln zu machen.

Dabei habe ich vier Spalten, die entweder ein x enthalten oder leer sind. In Spalte B stehen verschiedene Werte. Nun will ich eine Formel bauen, die die Zeilen gewichtet, je nachdem was in Spalte B steht und anschließend addiert.

Mit Hilfsspalten habe ich das Problem bereits lösen können. Die Formel, die ich dabei verwende lautet (exemplarisch für die erste Hilfsspalte):

=WENN(UND(C2="x";B2="jährlich");1;WENN(UND(C2="x";B2="halbjährlich");2;WENN(UND(C2="x";B2="vierteljährlich");4;WENN(UND(C2="x";B2="alle 2 Jahre");0,5;WENN(UND(C2="x";B2="alle 3 Jahre");0,33;"")))))

Anschließend kann ich die Summe der jeweiligen Hilfsspalten bilden.

Nun wollte ich fragen, ob es möglich ist eine Formel zu bauen, in der die Summenformel und die Formel für die Hilfsspalten gemeinsam enthalten sind um auf die Hilfsspalten verzichten zu können?

Da das Problem sehr speziell ist, habe ich eine Beispieldatei angehängt um es zu verdeutlichen.

Vielen Dank im voraus und viele Grüße,

wintwin111
Antwortento top
#2
Moin,

sofern ich dich richtig verstanden habe:

Arbeitsblatt mit dem Namen 'Tabelle 1'
CDEFGHIJ
56633,516,6618
57
586
59

ZelleFormel
C58=ZÄHLENWENNS($B$1:$B$53;"jährlich";$C$1:$C$53;"x")*1+ZÄHLENWENNS($B$1:$B$53;"halbjährlich";$C$1:$C$53;"x")*2+ZÄHLENWENNS($B$1:$B$53;"vierteljährlich";$C$1:$C$53;"x")*4
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg

Mein Formelvorschlag bezieht sich jetzt nur mal die Spalte B und viertel-, halb- und jährlich. Wenn's passt, musst du halt die Formel um deine weiteren Bedingungen erweitern und auf die anderen Spalten anpassen.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm,
wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
Hallo Günter,

die Formel ist genau das, was ich suche. Den Befehl ZÄHLENWENNS hatte ich für dieses Problem überhaupt nicht auf dem Schirm.

Vielen Dank und viele Grüße,

wintwin111
Antwortento top
#4
C58: =SUMME(ZÄHLENWENNS(C1:C53;"x";$B1:$B53;{"alle 3"."alle 2"."j"."h"."v"}&"*")*{2.3.6.12.24}/6)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste