Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Urlaubsliste SVerweis und Zählenwenn?
#1
Hallöchen!
 
Ich bin gerade echt an verzweifeln. Ich habe auf der Arbeit eine Excel-Tabelle für unseren Urlaub erstellt für alle Mitarbeiter.
 
Diese besteht aus 3 Tabellenblättern
 
1. Übersicht 2020
2. Urlaub 1 HJ
3. Urlaub 2. HJ
 
Leider ist mein Chef ständig der Meinung die Mitarbeiter anders zu sortieren und hat mir damit meine Datei mehr oder weniger zerschossen.
Nichts passt mehr  
 
Leider habe ich bisher keine Lösung gefunden wie es richtig berechnet wird.
 
 
Im ersten Tabellenblatt soll immer zusammengezähl werden wie viel Urlaub oder Krankheitstage der Mitarbeiter im jeweiligen Monat hatte.
 
In den anderen beiden Tabellenblättern trage ich Krank und Urlaub ein. Aus diesen Blättern soll Excel dann die enstprechenden Summen für die erste Tabelle ziehen.
 
 
Egal was ich bisher ausprobiert habe, es hat nichts gepasst. Vorher hatte ich in der ersten Tabelle mit Zählenwenn gearbeitet, was aber natürlich nicht mehr stimmt, wenn El-Chefo die zweite Tabelle anders sortiert  
 
Hat jemand eine Idee wie ich mein Problem lösen kann?


.xls   Urlaubsliste.xls (Größe: 97 KB / Downloads: 13)
 
Danke schon mal und ein schönes Wochenende!
Antwortento top
#2
Hola,

der Sinn hinter 2 Tabellen die identisch aufgebaut sind ist welcher?

Hier mal Urlaub für Halbjahr 1. Den Rest schaffst du dann alleine.


Code:
=SUMMENPRODUKT(('Urlaub 1. HJ'!$A$4:$A$8=$B3)*('Urlaub 1. HJ'!$B$4:$B$8=$C3)*(TEXT('Urlaub 1. HJ'!$G$2:$GF$2;"MMJJJJ")=TEXT(BE$1;"MMJJJJ"))*('Urlaub 1. HJ'!$G$4:$GF$8="u"))

Gruß,
steve1da
Antwortento top
#3

(10.07.2020, 08:05)steve1da schrieb: Hola,

der Sinn hinter 2 Tabellen die identisch aufgebaut sind ist welcher?

Hier mal Urlaub für Halbjahr 1. Den Rest schaffst du dann alleine.


Code:
=SUMMENPRODUKT(('Urlaub 1. HJ'!$A$4:$A$8=$B3)*('Urlaub 1. HJ'!$B$4:$B$8=$C3)*(TEXT('Urlaub 1. HJ'!$G$2:$GF$2;"MMJJJJ")=TEXT(BE$1;"MMJJJJ"))*('Urlaub 1. HJ'!$G$4:$GF$8="u"))

Gruß,
steve1da

Du meinst Tabelleblatt 2 und 3?

Es handelt sich um das 1. und 2. Halbjahr. Mein Chef arbeitet leider noch mit dem alten Excel. Da sind die Spalten begrenzt. Daher musste ich es aufteilen...

Leider verstehe ich die Formel nicht und weiß daher auch nicht was ich ändern muss. Bin leider kein Excel-Geek.
Antwortento top
#4
Hola,


Die Formel ermittelt die Anzahl der U‘s in Halbjahr 1. 
Für Halbjahr 2 musst du nur den Blattnamen in der Formel ändern und die Ergebnisse addieren.
Also =summenprodukt((.........))+summenprodukt((.....))
Gruß,
steve1da
Antwortento top
#5
(10.07.2020, 10:36)steve1da schrieb: Hola,


Die Formel ermittelt die Anzahl der U‘s in Halbjahr 1. 
Für Halbjahr 2 musst du nur den Blattnamen in der Formel ändern und die Ergebnisse addieren.
Also =summenprodukt((.........))+summenprodukt((.....))
Gruß,
steve1da

Es soll ja aber für jeden Monat ermittelt werden. Nicht nur für die beiden Halbjahre Huh

Und dann kann es passieren das der Chef im Blatt 2 und 3 die Reigenfolge der Mitarbeiter ändert.
Antwortento top
#6
Dann hast du die Formel nicht ausprobiert. Sie ermittelt das nämlich pro Monat.
Antwortento top
#7
(10.07.2020, 10:49)steve1da schrieb: Dann hast du die Formel nicht ausprobiert. Sie ermittelt das nämlich pro Monat.

Nein bisher nicht. Das mache ich gleich in meiner Mittagspause. Danke
Antwortento top
#8
Dann bewertest du etwas, was du noch nicht ausprobiert hast?
Nicht schlecht.
Antwortento top
#9
(10.07.2020, 11:08)steve1da schrieb: Dann bewertest du etwas, was du noch nicht ausprobiert hast?
Nicht schlecht.

Ich bewerte hier gar nichts. Wo habe ich denn bitte etwas bewertet?

Ich dachte hier bekommt man freundliche Hilfe und Antworten auf die Fragen die man stellt, ich versuche lediglich alles zu verstehen und stelle entsprechende Fragen dazu.

Keine Ahnung wo dein Problem gerade liegt.

Ich erwähne es aber gerne nochmal: Ich bin kein Excel-Geek
Antwortento top
#10
Zitat:Es soll ja aber für jeden Monat ermittelt werden. Nicht nur für die beiden Halbjahre



Du hast die Formel nicht probiert sagst aber was sie scheinbar nicht tut.
Ist auch egal, die Formel macht was du möchtest. Auch wenn die Reihenfolge der Mitarbeiter geändert wird.
Probier es einfach aus.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste