Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Unverständlicher NV# Fehler
#1
Hallo,

ich habe hier eine Datei, wo ich Zelle B2 per Dropdown eine Fahrzeugnummer auswähle, und dann per Sverweis den Rest der Daten ausfülle.
Mein Problem ist hier, dass wenn ich die Fahrzeugnummer 703.1 eingebe, ich den Fehler NV# bekomme. Ändere ich den Wert in der Tabelle 
aus dem Sverweis, so funktioniert alles wie es soll.


Ich bin mir sicher, dass ich hier nur eine Kleinigkeit übersehe, komme aber leider nicht darauf.


Gruß Markus


Angehängte Dateien
.xlsm   Bestellung Ausbildungsfahrten.xlsm (Größe: 84,39 KB / Downloads: 5)
Antwortento top
#2
Ein Dezimalzeichen-Problem nehme ich hier weniger an, als eine Falschschreibung (z.B. überflüssiges Leerzeichen in der Tabelle).

Wenn in der Tabelle mithin Zahlen als Texte stehen, sind sie nicht automatisch so sortiert wie Zahlen! Das solltest Du wissen.
Antwortento top
#3
sverweis mag sortierte!! Listen
Antwortento top
#4
Habe die Liste mal etwas geändert...
Wenn du darunter was schreibst wird sie automatisch länger...

Formel demnach angepasst, zu mindestens bei den ersten zwei!


.xlsm   Bestellung Ausbildungsfahrten.xlsm (Größe: 84,23 KB / Downloads: 3)
[-] Folgende(r) 1 Benutzer sagt Danke an Basisa für diesen Beitrag:
  • Dongiganti
Antwortento top
#5
Hallo,

wieder einmal Nichtbeachtung des 4. Parameters vom SVerweis. Wir der nicht gesetzt, gilt automatisch WAHR, was eine aufsteigend sortierte Liste erfordert. Setzt man auf FALSCH, braucht die Liste nicht sortiert sein, allerdings werden dann nur genaue Treffer gefunden.

Fahrplanbestellung

ABC
2Fahrzeug703.1
3Fzg. Länge14,95m
4Fzg. Gewicht49,5t
5HG 100Km/h
6Achsen2
7PZBJa
8LZBNein
9ETCSNein
10EbulaJa
Formeln der Tabelle
ZelleFormel
B3=SVERWEIS($B$2;Fahrplanbestellung!$S$1:$AE$15;2;FALSCH)
B4=SVERWEIS($B$2;Fahrplanbestellung!$S$1:$AE$15;3;FALSCH)
B5=SVERWEIS($B$2;Fahrplanbestellung!$S$1:$AE$15;4;FALSCH)
B6=SVERWEIS($B$2;Fahrplanbestellung!$S$1:$AE$15;9;FALSCH)
B7=SVERWEIS($B$2;Fahrplanbestellung!$S$1:$AE$15;10;FALSCH)
B8=SVERWEIS($B$2;Fahrplanbestellung!$S$1:$AE$15;11;FALSCH)
B9=SVERWEIS($B$2;Fahrplanbestellung!$S$1:$AE$15;12;FALSCH)
B10=SVERWEIS($B$2;Fahrplanbestellung!$S$1:$AE$15;13;FALSCH)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
[-] Folgende(r) 1 Benutzer sagt Danke an Klaus-Dieter für diesen Beitrag:
  • Dongiganti
Antwortento top
#6
Vielen Dank für die tolle Unterstützung!

Ich habe die Datei nochmals angepasst, jetzt läuft es. Hoffentlich denke ich beim nächsten mal an Eure Ratschläge.



Gruß Markus
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste