Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Umschlüsselungstabelle
#1
Hallo zusammen,

sorry wenn ich hier gerade alles falsch mache aber das ist mein erster Besuch in so einem Forum.

Ich möchte gern eine Tabelle erstellen die sich Daten aus einer Liste oder anderen Tabelle holt.
Bin leider auch hier totaler Anfänger...

Ich möchte in dieser Tabelle eine beliebige Autolacknummer eingeben und die Tabelle soll mir die Nummer der Spraydose, des Lackstiftes und die Bezeichnung auswerfen.  
Sie soll auch mit weiteren Lackdaten Listen erweiterbar sein. 

Wenn ich zb in mein Eingabefeld 190 eingebe soll (Bezeichnung) Amande  (Lackspray) 77 11 428 227  (Lackstift) 77 11 431 937 ausgegeben werden. 

Habe da mal was angefangen und benötige Hilfe. Kann mir jemand die erforderlichen Formeln basteln?


Besten Dank im voraus.


Angehängte Dateien
.xlsx   Lackomat.xlsx (Größe: 14,85 KB / Downloads: 5)
Antwortento top
#2
Moin

Verwende den SVERWEIS().
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
[-] Folgende(r) 1 Benutzer sagt Danke an shift-del für diesen Beitrag:
  • Abruzzi
Antwortento top
#3
Hier der Lösungsansatz für das erste Feld..,


Angehängte Dateien
.xlsx   Lackomat(1).xlsx (Größe: 15,28 KB / Downloads: 6)
Eine Menge reden, aber nichts sagen können viele...
[-] Folgende(r) 1 Benutzer sagt Danke an Frogger1986 für diesen Beitrag:
  • Abruzzi
Antwortento top
#4
Moin,

ich würde die Formel für die Bezeichnung so schreiben:
Code:
=SVERWEIS(B4;$E$1:$H$107;2;0)

Dann kannst du sie einfach in deine anderen beiden Zellen reinkopieren musst nur noch den Spaltenindex auf 3 bzw. 4 ändern.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm,
wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • Abruzzi
Antwortento top
#5
Ich wollte auch nur einen Ansatz zum ausarbeiten geben.. Wink
Eine Menge reden, aber nichts sagen können viele...
[-] Folgende(r) 1 Benutzer sagt Danke an Frogger1986 für diesen Beitrag:
  • Abruzzi
Antwortento top
#6

.xlsx   Lackomat.xlsx (Größe: 15,23 KB / Downloads: 3) Hallo,
habe die Eingabezelle mal mit der Datenüberprüfung versehen, hast weniger Tipparbeit.
Einfach in die Zelle klicken und Bezeichnung auswählen und zack ist das Ergebnis da.   05

Gruss Jo
[-] Folgende(r) 1 Benutzer sagt Danke an johammer für diesen Beitrag:
  • Abruzzi
Antwortento top
#7
Erst mal vielen Dank für den Lösungsvorschlag.

Da ich echt Anfänger bin, versuche ich gerade hinter die Logik zu kommen.
Wenn ich jetzt in meiner Datentabelle eine Zeile anfüge erkennt er es nicht, wahrscheinlich aufgrund der Datenprüfung.
Wie füge ich meine neuen Daten in die Prüfung ein? 

Es wäre auch gut wenn es bei einer nicht bekannten Nummer "unbekannt" auswirft statt einer Fehlermeldung.

Nicht lachen, ist für einen Anfänger echt schwierig. Hab schon etliches probiert gerade...


Angehängte Dateien
.xlsx   Lackomat Test.xlsx (Größe: 15,57 KB / Downloads: 4)
Antwortento top
#8
Hi,

die Änderung wird unter Daten/Datentools/Datenüberprüfung vorgenommen. Ich schlage aber vor, dass du deine Liste als intelligente Tabelle formatierst, dann werden zusätzliche Daten automatisch übernommen. Aktiviere irgendeine Zelle in der Tabelle und drücke STRG-T oder -L.

Die Fehlermeldung kannst du so für dich abfangen:
Code:
=WENNFEHLER(SVERWEIS($B$4;$E$2:$H$109;2;0);"unbekannt")
Gruß Günter
Jeder Fehler erscheint unglaublich dumm,
wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • Abruzzi
Antwortento top
#9
Das hat mir schon mal sehr geholfen. 

Tausend Dank

Werde es nun mal versuchen zu erweitern. Es tauchen sicherlich noch mehr Schwierigkeiten für mich auf.

In ein paar Jahren kann ich sicherlich hier auch mal jemandem helfen, lach....
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste