Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Übernahme Zellinformationen zwischen zwei Tabellen
#1
Ich habe in einer Excel Datei 2 Tabellen.
Diese stellen einen Vertretungplan (intern auf Schuldisplay, extern Online) dar.
Tabelle 1 ist intern auf dem Schuldisplay und Tabelle 2 soll ein Abbild für Online sein.
Bislang habe ich zur Übernahme der Felder aus Tabelle1 diese Formel stehen:
=WENN(ISTLEER(Tabelle1!B16);"";Tabelle1!B16) (hier für Zelle B16)
Es werden die eingetragenen Werte 1:1 übernommen, wenn sie leer ist, keine "0".

Folgendes wäre zusätzlich zu definieren:      (f.a. bedeutet fällt aus!)  .... bei kompletten Entfall:

Wenn "f.a." in Zelle (B16) in Tabelle1 steht, dann soll in entsprechender
Zelle in Tabelle2 "X" stehen. also "f.a." (Tabelle1) in "X" (Tabelle2) umwandeln.


jetzt wird es komplizierter...
.... bei Kurs Entfall:
Steht als Beispiel "Ma(XY)f.a." Bedeutet Mathe bei Lehrer XY entfällt in Tabelle1.
Hier muss jedoch im Online "Ma X" stehen, also ohne Lehrerkürzel. (wg. Datenschutz!)
Steht als Beispiel "Ku(Kw)f.a." Bedeutet Kunst bei Lehrer XY entfällt in Tabelle1.
Hier muss jedoch im Online "Ku X" stehen, also auch ohne Lehrerkürzel. (wg. Datenschutz!)

Wichtig!:
Wenn nun irgend etwas anderes da steht (also bei Vertretungen) soll dies gar nicht in dem Online Plan erscheinen also leer bleiben.

Wie könnte das gelöst werden? Vielen Dank! Jan
Antwortento top
#2
Hallo Jan,

stell mal bitte eine Beispieldatei vor - keine Bilder! mit eingetragenem Wunschergebnis. https://www.clever-excel-forum.de/Thread...ng-stellen
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
Hier ist meine Test Datei...im Anhang... hoffe das ist ok...

ich habe inzwischen weiter versucht .... mittels dieser Formel
=WENN(ISTLEER(Display!B16);"";Display!B16)&WENN(Display!B16="f.a.";"X")
nun erscheint f.a.X
hmmm grübel    Huh

ich noch mal ...habe die Tabelle ergänzt
....also dritter Tab....
so sollte es am Ende aussehen...


Angehängte Dateien
.xlsm   bleistift.xlsm (Größe: 229,36 KB / Downloads: 5)
.xlsm   so sollte es sein.xlsm (Größe: 235,98 KB / Downloads: 3)
Antwortento top
#4
Moin

Code:
=WENNFEHLER(WENN(SUCHEN("f.a.";Display!B16)>1;LINKS(Display!B16;2)&" X";WECHSELN(Display!B16;"f.a.";"X"));"")
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#5
Hallo shift-del,
vielen Dank! 18
Ich habe die Formel eingebaut und es klappte wunderbar.
Mein Chef kam noch und es gab noch den Hinweis, das es mehrere Wahlkurse geben könne.
Also WeA und WeB (Werken A, Werken B).... manche Kurse sind eben beliebt.
Ich konnte es lösen indem ich die !B16;2)&" in !B16;3)&" erhöht habe.

Ganz Wichtig! ...nun werde ich versuchen die Formel zu verstehen, also was da passiert... hoffe Tante google hilft 21


thx Jan
Antwortento top
#6
=WENNFEHLER(WENN(SUCHEN("f.a.";Display!B16)>1;LINKS(Display!B16;3)&" X";WECHSELN(Display!B16;"f.a.";"X"));"")

wie gesagt ich habe gegrübelt und hoffe das es einigermaßen hin kommt...

Formulierung der Formel:
Wenn ein Fehler auftritt schreibe "" (also leeres Feld)
...Suche in Display!B16 nach "f.a." wenn Erfolg (>1) schreibe nur aus dem Feld Display!B16 die ersten 3 Zeichen von Links und danach ein " X"
ansonsten (;) wechsele all Ausdrücke von "f.a." nach "X")
Antwortento top
#7
Code:
=WENNFEHLER(
   WENN(
      SUCHEN("f.a.";Display!B16)>1;
      LINKS(Display!B16;3)&" X";
      WECHSELN(Display!B16;"f.a.";"X")
   );
"")

Wenn die Fundstelle >1 dann gebe die ersten drei Zeichen von links aus und hänge noch " X" dran.
Anderenfalls (wenn die Fundstelle =1) dann tausche "f.a." durch "X" aus.
Falls die WENN()-Funktion einen Fehler auswirft dann zeige "".
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#8
Thumbs Up 
Nochmals vielen Dank!
Problem weniger... Angel 
vlg Jan
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste