Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Das Update ist abgeschlossen, Ihr könnt unser Forum jetzt wieder wie gewohnt nutzen. Eventuelle Bugs und Auffälligkeiten postet Ihr bitte im entsprechenden Forum im Bereich Forumstechnik. x


Sverweis
#1
Hallo zusammen,
eine kurze Frage bitte, ich check es ned...
Sverweis ist mein täglich Brot,... 
Dieser gibt einen gesuchten Wert aus der Matrix aus... funktioniert... wenn ich aber nicht denn gesuchten Wert ausgegeben bekommen möchte sondern
nur ein "OK" dann gehts ned weiter... 

Also Ergebnis sollte sein, wenn Sverweis funktioniert, dann gib "OK", ansonsten "ERROR".
Error hätte ich mit Wennistfehler hinbekommen,... aber das OK,... also das Ausgeben statt eines Wertes klappt ned.
Mit wennfehler(sverweis(A;B:C;2;0);"OK";"ERROR") klappt es ned.

Ich danke einer Idee.
LG Basti
Antworten Top
#2
Hallöchen,

reicht da nicht ZÄHLENWENN?
.      \\\|///      Hoffe, geholfen zu haben.
       ( ô ô )      Grüße, André aus G in T  
  ooO-(_)-Ooo    (Excel 97-2019+365)
Antworten Top
#3
Hi,


Zitat:Mit wennfehler(sverweis(A;B:C;2;0);"OK";"ERROR") klappt es ned.


Schau Dir mal die Formelsyntax von WENNFEHLER an. Die Funktion hat genau 2 Parameter:
=WENNFEHLER(Wert;Wert_falls_Fehler)

1. Wert steht hier für Deinen SVERWEIS
2. Falls der SVERWEIS nix findet (und es dadurch zu nem #NV-Fehler kommt), gibt es den Parameter Wert_falls_Fehler

Du hast aber 3 Parameter "verformelt" - und das geht natürlich nicht.

Zudem ist der Hinweis von André natürlich korrekt: In Deinem Fall reicht ZÄHLENWENN:
=WENN(ZÄHLENWENN(B:B;Suchwert);"OK";"ERROR")
Antworten Top
#4
"wenn" zählenwenn,... danke !!!
Dass ich darauf ned gekommen bin.
Tausend dank!
schnelltest Forum der Welt
-close-
Antworten Top
#5
Hi,

als Alternative könntest du auch eine Vergleich-Formel verwenden:

=WENNFEHLER(WENN(XVERGLEICH(A1;B:B);"OK");"ERROR")
Gruß,
Helmut

Win10 - Office365 / MacOS - Office365
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste