Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Summieren von glatten und krummen Summen getrennt voneinander
#1
Hallo zusammen,

benötige folgende Hilfe.
Habe in Spalte A eine Liste mit Umsätzen. Dort sind glatte Summen (z.B. 25,00) und krumme Summen (z.B. 13,69)
Die Liste ist so lang, dass händisches Umtragen nicht in Frage kommt.

Ich benötige nun in einer neuen Zelle die Anzahl der Umsätze mit krummen Summen sowie eine Zelle mit dem Gesamtumsatz der krummen Summen.

Aufrunden ist keine Option.

Vielen Dank schonmal

Gruß betzie


Angehängte Dateien
.xlsx   Beispiel.xlsx (Größe: 10,22 KB / Downloads: 3)
Antwortento top
#2
Hi

=SUMMENPRODUKT((GANZZAHL(A2:A20)=A2:A20)*A2:A20)
=SUMMENPRODUKT((GANZZAHL(A2:A20)<>A2:A20)*A2:A20)

Gruß Elex
[-] Folgende(r) 1 Benutzer sagt Danke an Elex für diesen Beitrag:
  • betzie_hh
Antwortento top
#3
Vielen Dank schonmal.

Das hat mir schonmal sehr weitergeholfen wobei mir bei der Anzahl alle Summen zusammen gezählt werden und nicht die Anzahl der Zellen mit krummen Summen.

Ich habe noch eine zusätzliche Tabelle wo das ganze nun noch erweitert werden muss.
Es kommt eine Bedingung dazu.
Jetzt sollen alle krummen Summem mit der Bedingung "Vielleicht" zusammen gezählt und auch die Anzahl berechnet werden.
Die Zählung findet auf Tabellenblatt zwei statt.

Beispiel hab ich angehängt.

Kannst Du da auch helfen?

Gruß Corinna


Angehängte Dateien
.xlsx   Beispiel.xlsx (Größe: 12,16 KB / Downloads: 3)
Antwortento top
#4
Hi

für Anzahl.
=SUMMENPRODUKT((GANZZAHL(A2:A65)<>A2:A65)*(B2:B65="Vielleicht"))

Summe bekommst du selbst hin. 32
Antwortento top
#5
Hey,
irgendwie bekomme ich es nicht hin. Wenn alles auf einem Tabellenblatt ist klappt es ohne Probleme. Habe ich die Rechnung aber auf einem zweiten Tabellenblatt und markiere als Bereich die Spallte des ersten Tabellenblatt, damit es dynamisch bleibt, bekomme ich #WERT.
Was mach ch falsch?
Und die Summenberechnung funktioniert irgendwie auch nicht bei mir.

Gruß betzie
Antwortento top
#6
Ok. Kein Problem, dann hier mit Datei.


Angehängte Dateien
.xlsx   Beispiel(1).xlsx (Größe: 12,2 KB / Downloads: 4)
[-] Folgende(r) 1 Benutzer sagt Danke an Elex für diesen Beitrag:
  • betzie_hh
Antwortento top
#7
Danke für Deine Geduld.

Mein Problem ist, dass ich die komplette Spalte markieren möchte damit ich Sie dynamisch verändern kann. Also mal mehr mal weniger Zeilen einfügen.
Mit Deiner Formel klappt das super bei einem festen Bereich. Bei der Spaltenmarkierung geht es nicht mehr.


Gruß betzie

Nachtrag: Hab es jetzt einfach gelöst im dem ich nicht das Tabellenende sondern die letzte Excelzeile die es in Excel gibt eingegeben habe.
Antwortento top
#8
Hat wenig mit Markierung zu tun.

PHP-Code:
=SUMPRODUCT(N(B2:B30000&(MOD(A2:A30000;1)<>0)="VielleichtTRUE")) 

PHP-Code:
=SUMPRODUCT(N(B2:B30000&MOD(A2:A30000;1)="Vielleicht0")) 
Zum übersetzen von Excel Formeln:

http://dolf.trieschnigg.nl/excel/index.p...gids=en+de
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste