Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Summewenns mit leerer Bedingung
#1
Question 
Guten Tag,
ich habe bereits eine Weile gesucht, aber leider nirgendwo eine Lösung gefunden. Ist wahrscheinlich recht simpel, aber ich komme nicht drauf
Ich habe eine Formel in etwa so:

=SUMMEWENNS(A1:A10;B1:B10;E2)


E2 ist in dem Fall ein Dropdown, wo ich verschiedene Bedingungen auswählen kann. In Wirklichkeit ist meine Formel deutlich länger und berücksichtigt viel mehr Bedingungen, das hier ist nur die abgespeckte Version.
Ich hätte gerne, dass wenn die Bedingung (E2) leer is, dass dann einfach alle Zeilen berücksichtigt werden, als würde es die Bedingung nicht geben.

Ich habe eine Excel Datei als Anhang zum Veranschaulichen, falls nicht klar ist, was ich meine. Bei der Lösung bitte berücksichtigen, dass ich nicht nur eine, sondern ganz viele Bedingungen habe (also meine Formel ist eigentlich deutlich länger), sonst hätte ich mir eine umständliche Lösung selber gebastelt.

Und ich hätte das Beispiel gern so schön eingebunden, wie ich es an anderer Stelle hier im Forum gesehen habe, aber ich habe leider nicht verstanden oder gefunden, wie man das macht, auch da wäre ich für einen Hinweis dankbar, damit ich für zukünftige Anliegen nicht extra Excel-Dateien hochladen muss.

Vielen Dank im Voraus!
LG Robert


Angehängte Dateien
.xlsx   Mappe1.xlsx (Größe: 10 KB / Downloads: 4)
Antwortento top
#2
=SUMMEWENNS(A:A;B:B;WENN(E2<>"";E2;"<>"))
Antwortento top
#3
Hallo Robert,

ich verstehe dein Problem nicht; wenn E2 leer ist, erscheint doch in C2 eine 0.
Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEFG
1BlaBlubAnzahlBedingungWUNSCH: Wenn ich E2 lösche, dass ich in C2 dann 13, anstatt 0 herausbekomme
21a0
31b

ZelleFormel
C2=SUMMEWENNS(A:A;B:B;E2)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg


Zitat:Und ich hätte das Beispiel gern so schön eingebunden, wie ich es an anderer Stelle hier im Forum gesehen habe, aber ich habe leider nicht verstanden oder gefunden, wie man das macht, auch da wäre ich für einen Hinweis dankbar, damit ich für zukünftige Anliegen nicht extra Excel-Dateien hochladen muss.


Schau mal hier: https://www.clever-excel-forum.de/Thread...darstellen
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#4
@LCohen
Genau das habe ich gesucht, vielen Dank für die super schnelle Hilfe, shame on me dass ich nicht selber drauf gekommen bin!
=SUMMEWENNS(A:A;B:B;WENN(E2<>"";E2;"<>"))


"ich verstehe dein Problem nicht; wenn E2 leer ist, erscheint doch in C2 eine 0."
Es soll dann die Summe erscheinen und nicht 0, siehe meinen Wunsch: "WUNSCH: Wenn ich E2 lösche, dass ich in C2 dann 13, anstatt 0 herausbekomme"

Danke für den Link, werde zukünftig die Formeln dann in das entsprechende Format übertragen.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste