Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Summewenns/Drop-down und Datumangaben
#1
Seid herzlich gegrüßt liebes Excel Forum,
ich wende mich an euch, weil ich mich schon seit zwei Tagen in ein Problem verrant habe. Ich möchte eine Summewenns Funktion mit sieben Kriterien füllen, die allesamt aus Dropdown Menüs gespeist werden. Bis dahin scheint das auch zu funktionieren, bis auf eine Ausnahme. Das Kriterium, mit dem ich die Jahreszahl angebe. Wähle ich z.B. 2019 aus, soll mir die Funktion aus einer festgelegten Spalte in einem anderen Registerblatt alle Werte aus 2019 aufsummieren. Die Werte sind im Format 01/01/2019 usw. notiert.

=SUMMEWENNS(DoA_BetragHauswährung;DoA_Konto;[@Konto];
DoA_Buchungsdatum;WENN(Debitorenreporting!$J$2="";"<>";Debitorenreporting!$J$2); 
DoA_Belegart;WENN(Debitorenreporting!$J$3="";"<>";Debitorenreporting!$J$3);
DoA_Topkunde;WENN(Debitorenreporting!$J$4="";"<>";Debitorenreporting!$J$4);
DoA_Geschäftsbereich;WENN(Debitorenreporting!$J$5="";"<>";Debitorenreporting!$J$5);
DoA_Mahnbereich;WENN(Debitorenreporting!$J$6="";"<>";Debitorenreporting!$J$6);
DoA_Mahnstufe;WENN(Debitorenreporting!$J$7="";"<>";Debitorenreporting!$J$7))

Der Fett markierte Parameter ist gemeint. Ich habe versucht das Problem wie folgt zu lösen. Für jedes auszuwählende Jahr sollte die Funktion

=SUMMEWENNS(DoA_BetragHauswährung;DoA_Konto;DBR[@Konto];DoA_Buchungsdatum;">=01/01/2019";DoA_Buchungsdatum;"<=31/12/2019";$J$2;"2019")

den passenden Wert an die erste Funktion übergeben. Der letzte Kriterienbereich und das passende Kriterium erzeugen am Ende aber nur die Fehlermeldung #WERT. Ich vermute, der gesamte Lösungsansatz ist erheblich zu umständlich aber ein besserer fällt mir par-tout nicht ein. Auch verschiedene Versuche mit der Funktion Indirekt wollten nicht zum Ziel führen. (Ich tue mich mit der Verarbeitung von Jahresangaben in Excel aber auch priinzipiell eher schwer).

Vielen Dank für eure Unterstützung.
Antwortento top
#2
Hallöchen,

nimm SUMMENPRODUKT, im Prinzip

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCD
101.01.20191Meier3
201.01.20201Meier
301.01.20191Müller
401.01.20192Müller
501.01.20192Meier
601.01.20193Mutzke

ZelleFormel
D1=SUMMENPRODUKT((B1:B6)*(JAHR(A1:A6)=2019)*(C1:C6="Meier"))
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#3
Hallo André und vielen Dank für deine Hilfe.
Leider weiß ich nicht, wie ich die Formel die du beschrieben hast in meine Formel integrieren soll.

DoA_Buchungsdatum;WENN(Debitorenreporting!$J$2="";"<>";Debitorenreporting!$J$2)
Irgendwo in dieser Zeile muss eine Prüfung statt finden, die alle Zellen im Bereich DoA_Buchungsdatum zurück liefert, welche zum Jahr 2019 (oder jedes beliebige andere Jahr, welches ich aus dem Dropdown Menü auswähle) gehören. Diese Zellen(Zelladressen oder wie auch immer) müssen natürlich auch mit den anderen Kriterien der ersten Summenfunktion zusammen passen bevor sie addiert werden bzw. das Kriterium das mit Jahreszahlen zu tun hat völlig ignorieren und anhand der restlichen Kriterien weiter rechnen.
Für die Auswertung der Nicht-Auswahl oder leere Auswahl habe ich auch "WENN(Debitorenreporting!$J$2="";"<>";Debitorenreporting!$J$2)" als Kriterium in die Summewenns Formel mit eingebracht.
Ich bin inzwischen der Meinung, dass mir weitere verschachtelte Summenfunktionen, egal welchen Typs, innerhalb der Hauptfunktion da nicht weiter helfen werden.
Um es zusammen zu fassen:
I)   Drop down Menü Eingabe: Jahreszahl
II)  Prüfung von DoA_Buchungsdatum und Ausgabe der Zellen, welche innerhalb des genannten Jahres liegen
III) Integration der Angaben in die Hauptfunktion
IV) Abstimmung mit den restlichen Kriterien
V)  Summierung der passenden Ergebnisse

Vielen Dank und entschuldige die Unannehmlichkeiten.
Antwortento top
#4
Hallöchen,
Du sollst da nix integrieren sondern statt SUMME Wenns dann SUMMENPRODUKT nehmen.
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#5
Guten Tag. Ich habe deiner Anregung folgend diese Formel zusammen geschustert:




=SUMMENPRODUKT(DoA_Konto=DBR[@Konto];
WENN($J$2="";"<>";(JAHR(DoA_Buchungsdatum)=$J$2));
WENN($J$3="";"<>";DoA_Belegart=$J$3);
WENN($J$4="";"<>";DoA_Topkunde=$J$4);
WENN($J$5="";"<>";DoA_Geschäftsbereich=$J$5);
WENN($J$6="";"<>";DoA_Mahnbereich=$J$6);
WENN($J$7="";"<>";DoA_Mahnstufe=$J$7))


Das Ergebnis: #Wert!



Hast du noch eine Idee?

P.S. Den Beitrag habe ich eben editiert, weil mir aufgefallen ist, dass mein Formel unnötig aufgeblasen war.
Antwortento top
#6
Hallöchen,

Bei SUMMENPRODUKT verwende ich statt Semikola den Stern als Multiplikationszeichen und Wenn hatte ich auch nicht dabei Huh
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#7
Die Art wie Argumente an die Funktion übergeben werden hat sich in meiner Version von Sternen nach Semikola verändert.
Die wenn Funktion brauche ich, damit die Summenfunktion auch dann funktioniert, wenn eines der Argumente "leer" ist.
Antwortento top
#8
Hallöchen.,

Hast du mal mein Beispiel 1:1 ausprobiert? Dabei sind aus meinen Sternen Semikola geworden?
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#9
Aus den Sternen sind keine Semikola geworden. Die aktuell übliche Notation ist nur eine leicht andere. Wenn ich alle Semikola durch Sterne ersetze sieht die Formel so aus:

=SUMMENPRODUKT(((DoA_Konto)*DBR[@Konto])*
(WENN($J$2="";"<>";(JAHR(DoA_Buchungsdatum)=$J$2)))*
(WENN($J$3="";"<>";DoA_Belegart=$J$3))*
(WENN($J$4="";"<>";DoA_Topkunde=$J$4))*
(WENN($J$5="";"<>";DoA_Geschäftsbereich=$J$5))*
(WENN($J$6="";"<>";DoA_Mahnbereich=$J$6))*
(WENN($J$7="";"<>";DoA_Mahnstufe=$J$7)))

Übersichtlicher wird sie dadurch leider nicht. Das Ergebnis ist dasselbe. #WERT!
Antwortento top
#10
Hallo,

zeige doch mal eine Beispieldatei.
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste