Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

=Summenprodukt mit Datum???
#1
Hallo zusammen,

ich bin kein Excel-Experte und bräuchte Eure Hilfe, wie ich mit der Formel =summenprodukt...  folgendes darstellen kann:

In der Zelle B2 in der "Tabelle 1" sollen die Mengen (Spalte K) der Bezeichnung A (Spalte J) aus den  Rechnungen "Abrechnung_allgemein" und "Abrechnung_QBB" (Spalte B) für Abrechnungsmonat Dezember (Spalte E) und Jahr 2009 (Spalte F) addiert werden. Danach dann für Januar und Jahr 2020 usw...

Es wäre super, wenn mir hier jemand erklären könnte, wie ich das mit der Formel "=summenprodukt" erstellen kann.

Eine weitere Frage ist, wie ich die Spalte E und Spalte F dann formatieren muss?

Im Anhang findet Ihr die Beispiel-Datei.

Fragen über Fragen. Ich komme einfach nicht weiter. Vielen, vielen Dank für Eure Hilfe!

Viele Grüße!
Seb


Angehängte Dateien
.xlsx   Beispiel_Summenprodukt.xlsx (Größe: 17,58 KB / Downloads: 5)
Antwortento top
#2
Hallo,

probier es mal so:
Code:
=SUMMENPRODUKT(Tabelle2!$K$2:$K$40*((Tabelle2!$B$2:$B$40="Abrechnung_allgemein")+(Tabelle2!$B$2:$B$40="Abrechnung_QBB"))*(MONAT([@[Monat/ Jahr]])=Tabelle2!$E$2:$E$40)*(JAHR([@[Monat/ Jahr]])=Tabelle2!$F$2:$F$40))
Gruß
Michael
[-] Folgende(r) 1 Benutzer sagt Danke an Der Steuerfuzzi für diesen Beitrag:
  • SebSeven
Antwortento top
#3
Hallo Seb,

etwas kürzer so:

Code:
=SUMMENPRODUKT((RECHTS(Tabelle2!B$2:B$99;3)={"ein"."QBB"})*(Tabelle2!E$2:E$99=MONAT([@[Monat/ Jahr]]))
*(Tabelle2!F$2:F$99=JAHR([@[Monat/ Jahr]]))*Tabelle2!K$2:K$99)

wobei ich empfehlen würde, Deine Datentabelle in Tabelle2 ebenfalls mit: "Als Tabelle formatieren"  in eine intelligente Tabelle zu wandel. Damit die Formel an diese angepasst werden kann und Du Dir keine Gedanken machen musst, wenn mehr Datensätze hinzukommen, als bisher in der der Formeldefinition vorgesehen.

Zu Deiner Zusatzfrage: Die Formate in Spalte E:F der Tabelle 2 musst Du nicht anders formatieren. Du musst nur Sorge dafür tragen, dass dort nicht aus Versehen Textwerte anstelle Zahlenwerte stehen.
Gruß Werner
.. , - ...
[-] Folgende(r) 1 Benutzer sagt Danke an neopa für diesen Beitrag:
  • SebSeven
Antwortento top
#4
Hallo und vielen Dank. Es scheint zu funktionierenSmile

Es ist vielleicht eine "blöde" Frage, aber wie kann ich erkennen, dass das richtige Jahr und Monat "gezogen" wird?

(MONAT([@[Monat/ Jahr]])=Tabelle2!$E$2:$E$40)*(JAHR([@[Monat/ Jahr]])=Tabelle2!$F$2:$F$40))
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste