Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

=Summe(Summewenns(... mit Datum?
#1
Hallo zusammen,
 
ich bin kein Excel-Experte und bräuchte Eure Hilfe, wie ich mit der Formel =summe(summewenns(.....   folgendes darstellen kann:

Siehe Datei im Anhang: 
In einer beliebige Zelle sollen die Rechnungsbeträge (Spalte J) der Bezeichnung A und Bezeichnung D (Spalte H) der Rechnung "NRW_Sued"  (Spalte B) addiert werden... für Januar 2020 und in einer weiteren Zelle die Rechnungsbeträge für Februar 2020.
 
Es wäre super, wenn mir hier jemand erklären könnte, wie ich das mit der Formel =summe(summewenns(...  erstellen kann.  
 
Vielen, vielen Dank vorab!!!


Angehängte Dateien
.xlsx   Beispiel Excel SummeWenns.xlsx (Größe: 13,63 KB / Downloads: 7)
Antwortento top
#2
Hola,

warum wird Zeile 19 nicht berücksichtigt?


Code:
=SUMMENPRODUKT(('Auto Report '!B2:B44="nrw_sued")*(MONAT('Auto Report '!E2:E44)=1)*('Auto Report '!E2:E44<>"")*(('Auto Report '!H2:H44="bezeichnung a")+('Auto Report '!H2:H44="bezeichnung d"))*('Auto Report '!J2:J44))

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • SebSeven
Antwortento top
#3
Hi,

ich weiß nicht ob das von Steve1da funzt.
aber wenn du mit dem Summewenns agieren möchtest MUSS das Datumsformat vorhanden sein. Aktuell hat das Datum keine Möglichkeit als Kriterium eingesetzt zu werden.

MfG
[-] Folgende(r) 1 Benutzer sagt Danke an CHASiN1994 für diesen Beitrag:
  • SebSeven
Antwortento top
#4
Vielen Dank für Eure Hilfe. Die Zeile 19 habe ich vergessen zu löschen. Kann also ignoriert werden. 

Ich werde es gleich einmal ausprobieren.Smile 

Wie kann ich das Jahr mit berücksichtigen? Zahlen aus 2021 werde ich in Zukunft auch in diese Tabelle aufnehmen müssen.
Antwortento top
#5
Hola,

als weitere Bedingung, genau wie der Monat = 1 abgefragt wird, mit Jahr().

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • SebSeven
Antwortento top
#6
Okay, das macht Sinn.Smile 


Was genau sagt der fettgedruckte Teil der Formel aus? 

=SUMMENPRODUKT(('Auto Report '!B2:B44="nrw_sued")*(MONAT('Auto Report '!E2:E44)=1)*('Auto Report '!E2:E44<>"")*(('Auto Report '!H2:H44="bezeichnung a")+('Auto Report '!H2:H44="bezeichnung d"))*('Auto Report '!J2:J44))
Antwortento top
#7
Hola,

der besagt dass leere Zellen beimengen Datumswerten nicht beachtet werden. Denn leere Zellen werden als 1 angesehen und das würde im Januar uU zu falschen Werten führen.

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • SebSeven
Antwortento top
#8
Heute lerne ich einiges dazuSmile

Ich hätte aber noch eine weitere Frage und zwar, wenn ich jetzt Beträge aus einer zweiten Rechnung addieren möchte, dann muss ich die Formeln nur mit einem + verbinden? Wie z. B. :

SUMMENPRODUKT(('Auto Report '!B2:B44="nrw_sued")*(MONAT('Auto Report '!E2:E44)=1)*('Auto Report '!E2:E44<>"")*(('Auto Report '!H2:H44="bezeichnung a")+('Auto Report '!H2:H44="bezeichnung d"))*('Auto Report '!J2:J44))+SUMMENPRODUKT(('Auto Report '!B2:B44="rpf_north")*(MONAT('Auto Report '!E2:E44)=1)*('Auto Report '!E2:E44<>"")*(('Auto Report '!H2:H44="bezeichnung a")+('Auto Report '!H2:H44="bezeichnung d"))*('Auto Report '!J2:J44))

Wäre das korrekt? 
Antwortento top
#9
Hola,

kommt denn das richtige Ergebnis raus?

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • Rudi'S
Antwortento top
#10
Hallo Seb,

steve1da war ja schneller.

Bei deiner vorigen Anfrage muss ich meine Antwort irgendwie nicht abgeschickt haben.

Hier mal meine tabellarische Erfassung für deine Suchangaben, besteht aus den selben Ansätzen, nur mit dem Verweis auf die festen Vorgaben
(damit du nicht in den Formeln die Werte ändern musst.)

Gruß Rudi


Angehängte Dateien
.xlsx   Beispiel Excel SummeWenns.xlsx (Größe: 17,83 KB / Downloads: 3)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste