Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Suche über mehrere Spalten
#1
Hallo zusammen,

ich hoffe Ihr könnt mir bei folgendem Excel-Problem weiterhelfen.

Im Sheet 1 habe ich mehrere Kunden-Nummern, die in den drei Spalten A bis C im "Sheet 2" gesucht werden sollen. 
Sofern die entsprechende Nummer aus Sheet 1 dort gefunden wurde, soll der Wert in Spalte D im Sheet 2 in der Spalte B im "Sheet 1" angezeigt werden.

SVERVEIS funktioniert leider nicht, da ich ja nur in einer Spalte suchen lassen kann. 

Eine Beispieldatei habe ich angehängt.


Besten Dank! Smile


Angehängte Dateien
.xlsx   Excel - Suche über mehrere Spalten.xlsx (Größe: 10,14 KB / Downloads: 7)
Antwortento top
#2
Hola,

https://www.herber.de/excelformeln/pages...ommen.html

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • Rudi20
Antwortento top
#3
Hallo


ungeprüft...


https://www.herber.de/excelformeln/pages...effer.html


LG UweD
[-] Folgende(r) 1 Benutzer sagt Danke an UweD für diesen Beitrag:
  • Rudi20
Antwortento top
#4
Hi Rudi,

SVERWEIS() schachteln:

Arbeitsblatt mit dem Namen 'Sheet1'
AB
1Customer #STATUS
280001234STATUS A
3def456STATUS A
4789000
5800034560
683442STATUS B
7800056780
8ghi456STATUS C
9845332STATUS B

ZelleFormel
B2=WENNFEHLER(WENNFEHLER(SVERWEIS(A2;Sheet2!$A$1:$D$19;4;0);SVERWEIS(A2;Sheet2!$B$1:$D$19;3;0));SVERWEIS(A2;Sheet2!$C$1:$D$19;2;0))
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • Rudi20
Antwortento top
#5
Thumbs Up 
Ich danke Euch für die schnelle Hilfe! 

Letztendlich war Günter's Lösung exakt das, wonach ich gesucht habe! Perfekt! Smile 
Antwortento top
#6
Hallo, ich habe das so verstanden..:

PHP-Code:
=INDEX(Sheet2!D:D;AGGREGAT(14;6;ZEILE($A$2:$A$19)/(Sheet2!$A$2:$C$19=A2);1)) 
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • Rudi20
Antwortento top
#7
Letztendlich sind alle Vorschläge hier zielführend. 

Gruß,
steve1da
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste